Transmission wont load anymore

Hello, i tried to install OpenVPN yesterday evetything went smooth i think but now im facing multiple problems.

First transmission gets killed.
> Loaded: loaded (/lib/systemd/system/transmission.service; enabled)

       Active: failed (Result: signal) since Mon 2017-10-02 07:13:48 WEST; 16min ago
      Process: 504 ExecStart=/usr/bin/transmission-daemon -f --log-error --allowed *.*.*.* (code=killed, signal=KILL)
      Process: 369 ExecStartPre=/bin/sleep 10 (code=exited, status=0/SUCCESS)
     Main PID: 504 (code=killed, signal=KILL)

Then i cant access my rp from outside, as i think the vpn connection is still open, how do i kill the VPN?

How have you start it?

Hi,

Assuming you’ve setup openvpn using systemd, you can stop it with:

sudo systemctl stop openvpn

Strange that you can’t access via ssh, should still be able to do so even when the tunnel is up; but the the mean time you need to connect a keyboard to your pi. Exit kodi and hit escape should bring the console, more details can be found here:

https://osmc.tv/wiki/general/accessing-the-command-line/

This is just guess work, we still need more details like fzinken says; so we can help resolve the transmission issue and sort out ssh.

Thanks Tom.

Oh sorry, heres the guide i used
https://www.backtrails.net/2017/04/30/openvpn-setup-for-private-internet-access-pia-vpn-raspberry-pi-3-osmc/

So it does kill the VPN but transmission wont load, openvpn is the only package i have installed yesterday. Everything was working fine. Maybe a new version got installed when using distri upgrade?

transmission.service - Transmission BitTorrent Daemon
   Loaded: loaded (/lib/systemd/system/transmission.service; enabled)
   Active: failed (Result: signal) since Mon 2017-10-02 12:46:43 WEST; 50s ago
  Process: 8047 ExecStart=/usr/bin/transmission-daemon -f --log-error --allowed *.*.*.* (code=killed, signal=KILL)
  Process: 8038 ExecStartPre=/bin/sleep 10 (code=exited, status=0/SUCCESS)
 Main PID: 8047 (code=killed, signal=KILL)

If you followed the guide you linked to, you’d have run

sudo apt-get install network-manager-openvpn

There’s a good chance that this has messed up something since AFAIK it’s not compatible with OSMC.

You could always try to remove it:

sudo apt-get purge network-manager-openvpn

then reboot. But no guarantees.

Thanks ot did remove the package but hasnt fixed the problem. Should i reinstall transmission?

If I were you, I’d:

  • Uninstall openvpn
  • Reinstall transmission (OSMC version)
  • Try to get transmission working first.
  • If no success, reinstall OSMC.

Where do i reinstall the osmc version from?

The MyOSMC app store.

Looks like i have to reinstall osmc:confused: i tried reinstalling transmission but im still getting the same error. I dont want to redo everything is there a way to back up configs etc etc?or is there something else i can try

Job for transmission.service failed. See ‘systemctl status transmission.service’ and ‘journalctl -xn’ for details.
osmc@osmc:~$ systemctl status transmission

  • transmission.service - Transmission BitTorrent Daemon
    Loaded: loaded (/lib/systemd/system/transmission.service; enabled)
    Active: failed (Result: signal) since Wed 2017-10-04 07:01:36 WEST; 9s ago Process: 4159 ExecStart=/usr/bin/transmission-daemon -f --log-error --allowed ... (code=killed, signal=KILL)
    Process: 4150 ExecStartPre=/bin/sleep 10 (code=exited, status=0/SUCCESS)
    Main PID: 4159 (code=killed, signal=KILL)

Here are the logs if it can help

Https://paste.osmc.tv/ojusevanuh

Have you never explored the MyOSMC add-on at all? That will backup only your Kodi config. You’ll have to grab any other configs for anything else you’ve installed yourself.

Yes of course i did. I backed up kodi there but seems i have to backup my other configs and dbs individually. So logs show nothing?just want to attempt everything before starting over