Hi, I installed transmission daemon on my pi2 with apt-get a while back and always had this problem, basically when I add a torrent or magnet link it adds ok, but the web gui is unreachable for a minute or 2 afterwards, then it works fine as expected.
During the time the gui is unreachable I can ssh into it fine, and other web interfaces I have work fine also, it’s just transmission.
I’ve always had it setup to download to an external drive also, I’ve tried reducing the peers and limiting the download speed but the behaviour is the same no matter what I try.

Has anyone else experienced this, or hopefully, know of a fix for it?

I noticed there is a way of installing transmission through the OSMC App Store, although that’s the same version (2.8.4) …is there any benefit of having the OSMC version installed?


The OSMC version of Transmission has been optimized to work with OSMC. If you’re having problems with the Debian build, it probably makes sense to try the version from the OSMC App Store.

I’d recommend that you remove the old version using apt-get before installing it (don’t use apt-get purge), though that might possibly also remove your configuration and your .torrent history. If you want to take a backup of everything from the old (Debian) transmission installation, you can find it under /var/lib/transmission-daemon (needs root to access all files). Also take a copy of /etc/transmission/settings.json (needs root).

Thanks, I’ll try the OSMC version and see if that makes any difference.

Make sure to purge the older packages fully first.


Thanks Sam…you mean just the transmission-daemon package? Or are there dependencies that I should purge also?

Don’t purge – you could lose data. Or if you purge make a backup first.


I have an issue here Sam, i made a backup and purged the package and rebooted.
Now I’m unable to install anything from the OSMC App Store, I’ve tried both transmission and the cron job package, when i select install on the package and then apply, i get the sad face and OSMC restarts, not the Pi, just the kodi side of things.
I should point out I’m using the latest Kodi 18 alpha build from here, as i need a recent audio fix thats only recently been included in the alpha build…i presume thats probably the cause?

Debug log:

Is there anyway to install the OSMC transmission package via command line until this issue can be resolved?
And do u want me to report this over in the Alpha thread?

To install OSMC Transmission from the command line:

sudo apt-get update
sudo apt-get install armv7-transmission-app-osmc

Cheers, this version has definitely made a difference, it hangs slightly, but just for a few seconds, I can live with that…much better than before.