Trassmision 403: Forbidden

hallo all
i installed transmission throug OSMC “app store” but when ever i go to http://Local_IP_Address_of_RPI:5050
i get this error:

403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you’re editing settings.json, see the ‘rpc-whitelist’ and ‘rpc-whitelist-enabled’ entries.

If you’re still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

what to do?
just reinstalled OSMC onto a formatted Micro SD Card :smile:

also, how do i change username and password of transmission when i get it to work ??? :smile:

Use ssh and edit “/home/osmc/.config/transmission-daemon/Settings.json”
‘rpc-whitelist-enabled’ to false. The username and pass is also there (not sure).

thansk
but the settings.json is just blank, nothing is in there what so ever

Can someone upload the complete settings.json so we can make this the default?

Thanks!

Sam

found it

{
“alt-speed-down”: 15,
“alt-speed-enabled”: false,
“alt-speed-time-begin”: 540,
“alt-speed-time-day”: 127,
“alt-speed-time-enabled”: false,
“alt-speed-time-end”: 1020,
“alt-speed-up”: 15,
“bind-address-ipv4”: “0.0.0.0”,
“bind-address-ipv6”: “::”,
“blocklist-enabled”: true,
“blocklist-url”: “http://list.iblocklist.com/?list=ydxerpxkpcfqjaybcssw&fileformat=p2p&archiveformat=gz”,
“cache-size-mb”: 4,
“dht-enabled”: true,
“download-dir”: “/media/NASDRIVE/Torrent_complete”,
“download-limit”: 100,
“download-limit-enabled”: 0,
“download-queue-enabled”: true,
“download-queue-size”: 5,
“encryption”: 1,
“idle-seeding-limit”: 30,
“idle-seeding-limit-enabled”: false,
“incomplete-dir”: “/media/NASDRIVE/Torrent_inprogress”,
“incomplete-dir-enabled”: true,
“lpd-enabled”: false,
“max-peers-global”: 200,
“message-level”: 2,
“peer-congestion-algorithm”: “”,
“peer-limit-global”: 240,
“peer-limit-per-torrent”: 60,
“peer-port”: 51413,
“peer-port-random-high”: 65535,
“peer-port-random-low”: 49152,
“peer-port-random-on-start”: false,
“peer-socket-tos”: “default”,
“pex-enabled”: true,
“port-forwarding-enabled”: true,
“preallocation”: 1,
“prefetch-enabled”: 1,
“queue-stalled-enabled”: true,
“queue-stalled-minutes”: 30,
“ratio-limit”: 2,
“ratio-limit-enabled”: false,
“rename-partial-files”: true,
“rpc-authentication-required”: true,
“rpc-bind-address”: “0.0.0.0”,
“rpc-enabled”: true,
“rpc-password”: “{46949fbf39bfeec6dc9d4bff9f40c3f52219a4260yk9yGNo”,
“rpc-port”: 9091,
“rpc-url”: “/transmission/”,
“rpc-username”: “transmission”,
“rpc-whitelist”: “127.0.0.1”,
“rpc-whitelist-enabled”: false,
“scrape-paused-torrents-enabled”: true,
“script-torrent-done-enabled”: false,
“script-torrent-done-filename”: “”,
“seed-queue-enabled”: false,
“seed-queue-size”: 10,
“speed-limit-down”: 100,
“speed-limit-down-enabled”: false,
“speed-limit-up”: 100,
“speed-limit-up-enabled”: false,
“start-added-torrents”: true,
“trash-original-torrent-files”: true,
“umask”: 7,
“upload-limit”: 100,
“upload-limit-enabled”: 0,
“upload-slots-per-torrent”: 14,
“utp-enabled”: true
}

only problem is
i saved it, now i need to write this command

sudo service transmission-daemon reload

but it says:
transmission-daemon unrecognized service

see also
http://www.techjawab.com/2014/08/how-to-install-transmission-on.html

I believe the service is named ‘transmission’, and OSMC is using systemd, so it would be:
sudo systemctl stop transmission
Edit the settings.json
sudo systemctl start transmission