Trouble starting Home Cinema


My material:

  • Onkyo TX RZ 820 Amp (Connected to HDMI 2 ARC from Oled TV)
  • LG Oled 55B7V TV
  • Orange Cable TV Decoder (Connected to HDMI Onkyo CBL / SAT Amplifier)
  • Vero 4K (Connected to HDMI Onkyo Amplifier STRIMBOX)
  • PS4 Pro (connected to HDMI Onkyo Amplifier Game)
  • Panasonic Blu Ray DMP DB80 (Connected to HDMI Onkyo BD / DVD Amplifier)
  • Pronto TSU9400 remote control

When I want to watch TV, my Pronto starts up:
The Orange TV decoder
then the LG TV
then the Onkyo amp
select the CBL / SAT HDMI input on Onkyo.
I have my image ok Orange TV on the screen but after 15 seconds appears the screen of the Vero 4K, as if it was a priority.
Would anyone tell me what to change so that the Vero screen does not appear?
Thank you for your help.

Can you explain what you mean? Are you trying to hide the splash screen?

I would guess the CEC control in the Vero 4k is switching the input. If you’re using any kind of control system it’s worth turning CEC control off.

Ah, I see what he’s asking

Try disabling set active source in Kodi

Thank’s Sam,
Can you tell me here is this setting ?

Under Settings -> Input -> Peripherals

I need the CEC control to control the vero with my Pronto remote.

I’m not sure why. It seems your proto is an IR remote. V4k has an IR receiver and can be configured relatively easily.

In Input Parameters, Devices, there is CEC Adapter. That’s all.
Should I remove it?
If I remove it, I will not be able to use the pronto to manage the vero, right?

No, select it. There are configuration options there.

In configuration options, i don’t see : disabling set active source in Kodi.

Try “Switch source to this device on startup” if that doesn’t help I think next step is to enable CEC debug logging and upload.

Apparently, the problem is not the Vero but the CEC function of the Onkyo amp. If I disable the CEC of the amp, no problem.
Thank you to everyone who helped me.