TV channels (services) not working in TVheadend, but work in HDHR App

I have two HDHomeRun tuners, one in ATSC mode the other in ClearQAM mode (not sure that is important) and two RPi2 devices running the latest OSMC. One RPi2 has the TVheadend server and client running on it while the other just has the client connected to the server on the other RPi2. Everything is connected with ethernet cable… no wrieless. I also have the HDHomeRun Kodi app running on the RPi2 that has the TVheadend server. Some channels from the ClearQAM HDHomeRun tuner fail to play through TVheadend, and the behavior is the same on both RPi2 devices. However, that same channel will play just fine using the HDHomeRun app. Could it be a TVheadend server setting? Anyone else have a similar experience?

Hi.

You should test your tunes in a smaller setup, like without the kodi addon installed/enabled… a tuner can only be used my one application at a time…

the hdhomerun kodi addon does not use tvheadend, but connects directly to the tuner.

like first finde out what works, and then what not works…

-H

HarryL,

Sorry for the confusion. So yes, i’ve tried to isolate the issue… the tuner itself seems to work well. That was the intent of the comment about the HDHR Kodi addon (sorry i kept calling it an app). Using this addon, all channels play beautifully with the RPi2 hardware. And, i understand that the addon doesn’t use the TVHE backend server. That’s why i suspect there is some sort of setting in my server configuration that is not right. However, this was working well, that is, all channels playing well through the TVHE server prior to some recent OSMC updates. So, i’m also suspecting that some system configurations/settings could also be an issue. I double checked the OMXPlayer setting and it is still enabled. However, i noticed the MMAL accelerator was also enabled and don’t recall if that was enabled before or not. So now i have two accelerators enabled. Is this an issue?

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Ok, here we go…

  • The issue you are currently experiencing with OSMC: When attempting to tune to a channel/service using TVheadend client connected to a TVheadend server running on the same RPi2 OR a different RPi2 (both wired connections), the channel/service does not play, or the audio is present with no image, or there is a really weird looking vertical bar. Occassionally, this locks up OSMC’s responsiveness to the remote and i have to reboot the machine via ssh from another machine
  • What you were doing when this issue occurred: Nothing special, just attempting to select a service from the Guide within TVheadend client. Also happens when selecting a channel from the Channel list (not the Guide)
  • Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.: Yes, it happens on both RPi2 devices when i tune to a select few channels. Other channels work fine. For the channels that have an issue through TVHE, i can watch those channels just fine through the HDHR Kodi addon
  • The device you are currently running OSMC on: 2 different RPi2 devices, both with plenty of power available
  • What peripherals are attached to the device: both have a USB IR remote dongle connected one has a USB wireless keyboard and the other has a USB memory stick
  • Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?: i’ve had a lot of OSMC updates lately and i’ve been allowing all updates. I’ve also recently added the second RPi2 (with the TVHE client) to the network. It seems that the issue started after connecting the second RPi2, but not right after, that is, it worked for a while with both RPi2 devices, but then started acting up. So, it’s hard to tell if it has anything to do with an update or the addition of the second RPi2.

I will try and remove the second RPi2 from the network (or disable the TVHE client) and see if that helps.

I will grab some log files this evening and post a link here.

No new addons for the first RPi2 that was working fine; new RPi2 got the TVHE backend

I can use the web interface to the HDHR to see what mode it’s in and what the format of the stream is in. In addition, i will load MediaInfo tonight and see if it can detect the format/container/properties of the stream that is giving me a problem.

If i can screen shot the vertical bar, i will.

Thanks again… I have some action items from above that i will get to tonight.

@HarryL, So thanks for the pointer to the “how to help us help you” link. I pulled the power on the second RPi2 and the issue went away. I plugged power back to the second RPi2 and the problem came back. I disabled the tuners in the configuration of the TVHE server (kinda like disabling or removing the server) on the second RPi2 and the problem went away. So, it looks like you cannot have two TVHE servers on the network.

I was doing this due to a problem i was having on the second RPi2 where the channel/service stream was “flaky”. Sometimes, in the middle of watching a program, the sound and video would get messed up and “glitch” (not the same type of glitching that you see with the OMXPlayer disabled, more like a time synch issue with sound pitch being too high or too low like you were playing an old record on the wrong speed). Anyhow, i figured it was a network issue since i only see this problem on the second RPi2 (the one without the server). So, now i’m back to that problem. Any ideas on that?

Thanks again for pointing me to a methodical debug approach.

Hi,

Super that you found the problem ;-).

you can have more then one tvheadend server on the network, but you need to change the name on at least one of them… so not both of them broadcast it’s name as tvhaedend.local… at the time i was running to tvheadend servere on my network i compiled them both, so i just at the configure line disabled avahi… but that was a few years ago don’t know if thats enough now.

-H

ps. I can’t find any info online on how to disable avani with tvheadend!.

update: or just on the client enter the exact IP and don’t use tvheadend.local/tvheadend as server address in the addon config.

So i understand your suggestion to not name them both the same thing, i.e. tvheadend.local, but i don’t know how to change the name since i am installing from the OSMC app store. I will look in the server configuration to see if there is anything regarding the server name or if i can disable broadcasting (that is, broadcasting the name). Also, regarding your update to your post above, I have always used the actual IP address in the client configuration. But i’m thinking this has nothing to do with the suggestion to rename the server, so i’m not sure what your intention was with the comment regarding the use of the server IP address in the client configuration.

Keep in mind that when the problem existed, both clients/addons, running on different RPi2s, were pointed to the SAME server, but a second server existed on the other RPi2, i just hadn’t yet configured the second client to point to the server running on the same machine. So, here was the configuration:

RPi2.1:
TVHE server running and configured to use HDHR.1 and HDHR.2 on the network (only 2 HDHR devices on the network)
TVHE client/addon running and configured to point to server running on RPi2.1

RPi2.2:
TVHE server running and configured to use HDHR.1 and HDHR.2 on the network (only 2 HDHR devices on the network)
TVHE client/addon running and configured to point to server running on RPi2.1

update: I’ve looked all over and i can’t find any configuration menu for the server from within OSMC. I’ve looked all over the web configuration pages for the server and i can’t find any sort of naming option for the server.

in kodi go too:
SYSTEM -> Add-ons -> My add-ons -> PVR Clients
chose “Tvheadend HTSP client” and configure.

What host name do you have there?

-H

192.168.1.140

@HarryL, so i’ve been conversing with someone on the TVHE forums for a different issue and he mentioned something that might be pertinent to my issue of having two TVHE servers running on my network. He mentioned profiles, and how he uses two different profiles to manage his recordings. Evidentally, each profile manages its own log files. So, that got me thinking. My two RPi2s are each named differently on the network (i at least thought about that when i set up the second one), but the profile name is the same on each… osmc. Do you think creating a new profile with a different name one one of the RPi2s would resolve the interaction/contention issue of the two TVHE servers?

re name issue:
The Problem is not OSMC it’s that tvheadend default always use “tvheadend”.local as name on the network… i have not found an easy way to disable that.

re: RPI2 1/2
you can’t have to/2 TVheadend setup connected to the same tuner…

RPi2.1:
TVHE server running and configured to use HDHR.1 and HDHR.2 on the network (only 2 HDHR devices on the network)
TVHE client/addon running and configured to point to server running on RPi2.1

RPi2.2:
TVHE server running and configured to use HDHR.1 and HDHR.2 on the network (only 2 HDHR devices on the network)
TVHE client/addon running and configured to point to server running on RPi2.1

you can have one tvheadend server setup connecting to both of them, so one rpi2 have 4 tuners connected…

so like RPI2.1 is running all tuners(hardware), and RPI2.2 is connecting to RPI2.1’s tvheadend for info… should work.

or have RPI2.1 connect to HDHR1, and RPI2.2 connect to HDHR2.

-H

OK, I have pretty much come to the same conclusion with all my various configuration attempts. I would have thought that the assignment of a resource (a tuner within one of the HDHR devices) would be dynamically assigned to a server, but it seems each tuner is assigned to the server that was configured for its use. Thanks for the confirmation of this configuration limitation.

Yes this “works” though the stream was not stable on the RPI2.2. I don’t watch the TV connected to RPI2.1 that much, but i also don’t remember there ever being a problem with that stream with the configuration you outlined. So, i enabled the server on RPI2.2 and disabled the server on RPI2.1, then connected both RPI2s to the server on RPI2.2 and I STILL have the instability on the RPI2.2 as well as the RPI2.1. So, I was able to confirm that it is not the extra traffic on the network that is/was causing the instability with the stream. By the way, everything is wired with CAT6.

So, i’m now left suspecting that it is a limitation of the RPi2 hardware, something not quite right with the TVHE build for OSMC, or (more likely) some configuration setting within OSMC that i haven’t figured out yet (yes, i have both CODECs on both RPi2s and I have the OMXPlayer enabled on both RPi2s). Next step would be to use a PC i have sitting around to load Linux+Kodi+TVHE and redo the TVHE server configuration on that machine… the wife is running low on patience with me at the present time, so it might be a while before i try that.