Tv loses connection with the vero or screen goes blue and vero stops responding until I pull the plug it out and into power again

I first noticed it this morning my 4K+ wasnt sending a video signal to the tv when I turned on the tv. I tried to ssh into the device but that didn’t work. So I pulled the plug and plugged it back in and the device started right up. I was browsing my library and when I wanted to start a movie the loading indicator came up like it always does and then again the 4k+ lost the connection with the tv and become unresponsive and not reachable via ssh. I plugged it out and in again and it worked fine while playback but a few seconds after playback of a show stopped the screen became fully blue and the 4k is unresponsive and not reachable via ssh.

Not sure how to get logs after crash since device is not recharge via ssh

Picture of the mentioned blue screen attached


This time it crashed a few seconds after playback started screen blue again but darker blue this time, I had logging enabled when it happened but as said before device is unresponsive and I can’t ssh into it to upload the log

Kodi stores two sets of logs so, we get the crash on the kodi.old.log

ssh in when restarted and grab-logs -A, and as usual post url


After I pulled the plug and plugged and plugged it back in vero started booting as usual but then the screen turned black but the tv still had a connection with the device. Ssh didn’t work so I had to pul the plug again and reboot again this time it’s up and I could ssh in and post logs

Try re-installing OSMC.


Will do but probably tomorrow because I’m about to head out, thanks

Just reinstalled osmc but my 4k+ froze during the initial setup, reinstallation was successful but the device bacame unresponsive while I was changing settings and browsing the menus, it’s not reacting to remote or ssh, The only thing I can do is pull the plug. It crashed again a few minutes later I was able to grab a log

And again

Is the device plugged directly in to the wall?



Thanks for confirming, and for the image.

Can you try powering the device with a USB cable (disconnect PSU)?
Failing that, there may be an issue with the device and it may need to be replaced under warranty.

1 Like

Usb cable goes into the white usb port correct? Where should I get power? I have an iPhone and iPad charger that are usb with a detachable lightening cable is it ok to test ?

Not ideal but should work for a test without external USB devices on the Vero

1 Like

I just checked and according to google the OG iPad Pro 10.5 inch that I have comes with a 12 watt 2 amps charger.

For testing everything 5V with >1A should be fine. Even the PC USB Port might work

1 Like

finding a usb to usb cable is the hardest part all mine are from the era they had some kind of proprietary connector on one end to plug into a specific device

Out of town now so I’ll test this once I’m back home

I cant find this specific usb cable I would need at home I only have usb to usb mini and or some older versions at home.

Can @sam_nazarko give me the specific spec of the cable to buy?

So I can test this?


From your picture, it looks like you could have damaged the power supply with the way you’ve plugged it in to the wall.

You just need a USB A cable.

I just looked at it and that’s the only way I could plug it in if I put the plug vertically the pins wouldn’t align with the holes in the socket. I have a standard Eu sockets at home so if this was the wrong way to plug it in I think you’d have a lot more Customers from the Eu with broken power supplies because if you want to plug the vero power supply directly into the wall and not into a splitter that’s the only way to do it

Will grab a UsbA to usbA cable to test and report back tomorrow

Sadly no luck @sam_nazarko my 4k+ is now connected to the iPad Pro charger with a Usb A to usb A cable and still crashing almost instantly after It starts up.

Something interesting just happened, While I was testing the crashing 4k+ The vero remote died on me and because I don’t have a replacement battery in the house I connected the remote app for iOS. Since I’m using the iPad remote and not the physical one my 4k+ stopped crashing. I swapped back to the legit power supply and all SeemsGood so far.

Could it be that a failing battery can crash a system?

Thinking back the vero did always crash while I was browsing the menu’s

I’ll grab a new battery Monday just to be sure