TV series not recognized

Im trying to put a season of MASH on my OSMC server, but unfortunately i cant get it to pull metadata. when trying to use a naming server to tailor the filename to TVDB, but it tries to use asterixs, which you cant use in filenames. I have tried to use it without the symbols, but i cant get it to find the metadata no matter what I do. on the TVDB website i can find MASH, so i know it should be able to find it.

Any Ideas?

http://kodi.wiki/view/Naming_video_files/TV_shows

I saw that page, and I followed what it said, i just create a folder right? name it MASH? put all the files in it? named as it told me to?

I remember having similar trouble with MASH, the movie. Ended up having to put dots “.” in the name (including one at the end) and then it worked: M.A.S.H. (1970). Maybe something similar would work for the TV series?

As @berto wrote, you may have to substitute the * with something. Read also here Special Characters in TV Series Name - TheTVDB.com

I had trouble with MASH too. I ended up making a folder called “MASH” and used tinyMediaManager to scrape the episodes. It works. I know I haven’t offered much new information, but I wanted to let you know, that it does work. Good luck.

How did you use tinymediamanager? scrape for metadata on windows, and move it on to osmc? Thanks for your input!

followed what the TVDB forum had posted, still nada, I haven’t ever tried setting up TV series in OSMC, so i may be doing that incorrectly. I just need to create a folder, name it “M.A.S.H” and put the episodes inside right? format the episodes as: “M.A.S.H - 1x01 - MASH the Pilot” correct? Thanks so much for your help!

I have that show and I just made a MASH folder and thetvdb scrapped it fine. You shouldn’t need to do more then that.

how are your file names formatted? could you post a screenshot?

ls MASH
MASH.s01e01.MASH.-.The.Pilot.mkv
MASH.s01e02.To.Market,.to.Market.mkv
MASH.s01e03.Requiem.for.a.Lightweight.mkv
MASH.s01e04.Chief.Surgeon.Who.mkv
MASH.s01e05.The.Moose.mkv

Are you saying that you have not yet specified a source location and scraped the media yet? Because you won’t get metadata until this is done.

Forgot to mention that some of the episode titles can cause problems so remove special characters from them also like the CAV*E and some episodes start the title with a number which can cause the scraper to think it is a multi episode file. In cases like that I just renamed the episode title to replace the number with it spelled out as a word. Example s02e02.5.O’Clock.Charlie became s02e02.Five.O’Clock.Charlie

Make sure your folder structure is correct:

Hard drive
TV shows
MASH
MASH.s01e01 - {episode name}

And yes scrape the show with tmm, then have OSMC locally scape the files from your hard drive.

hey shadow, are you using a scraper before OSMC? or going through it? im still not getting metadata. also, does it make a difference that im using the Kodi front end instead of the default OSMC?

I just used the built in TVDB scraper. No external scraper programs.

As ActionA already asked you have to explain what you mean with this. Did you add your series folder via Add Source to get it scrapped?
If yes then enable debugging, try to scrape and share your log files
To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Well, im sorry, I made a stupid mistake, and had my entire external hard drive mounted as a source instead of the “Movies” and “TV Shows” inside. I changed that and it works now. Thanks for all of your help, at least I learned a bit more about OSMC in the process!

out of curiosity, one more thing, do i need to have the actual name of the episode in the filename? if i do, is there a easier way of changing all the filenames to the correct names? Thanks!

No you don’t need it really you don’t even need to show name since that is read from the folder.

just the season and episode in either s01e01 or 1x01 format.

I like having them and use a program called filebot to bulk rename them. It can be configured to name them exactly like you like them. It gets the episode names from thetvdb and matches them up to the season and episode number.