TV turn on, without interaction


I have a Panasonic P42G20 TV, so not so new, but working well TV. Osmc connecting directly to the TV.

I tried to check the cec-client -m, how ever it gives back an error that it could not open a connection.
cec-client -l was working.
libCEC version: 6.0.2, compiled on 2021-02-21 00:19:23 by root@compiler2 on Linux 4.19.0-9-amd64 (armv7l), features: P8_USB, DRM, P8_detect, Linux
Found devices: 1

device: 1
com port: Linux
vendor id: 0000
product id: 0000
firmware version: 0
type: Linux

After watching the episod, stopping somewhere in it:
STOP: (last log line)
2021-09-26 22:38:39.411 T:573 DEBUG : CDRMUtils::DrmFbGetFromBo - using modifier: 0x700000000000001

POWER OFF the TV via remote control: (last log line)
2021-09-26 22:39:34.073 T:767 DEBUG : CecLogMessage - >> 0f:36

and then wakeup starting from here.

2021-09-26 22:39:50.517 T:767 DEBUG : CecLogMessage - CLinuxCECAdapterCommunication::Process - CEC_DQEVENT - CEC_EVENT_STATE_CHANGE - log_addr_mask=0000 phys_addr=ffff
2021-09-26 22:39:52.535 T:767 DEBUG : CecLogMessage - changing physical address to FFFF
2021-09-26 22:39:52.535 T:767 DEBUG : CecLogMessage - SetDevicePhysicalAddress - not setting invalid physical address ffff
2021-09-26 22:39:52.536 T:767 DEBUG : SetConfigurationFromLibCEC - settings updated by libCEC
2021-09-26 22:40:00.794 T:767 DEBUG : CecLogMessage - CLinuxCECAdapterCommunication::Process - CEC_DQEVENT - CEC_EVENT_STATE_CHANGE - log_addr_mask=0000 phys_addr=1000
2021-09-26 22:40:00.928 T:767 DEBUG : CecLogMessage - CLinuxCECAdapterCommunication::Process - CEC_DQEVENT - CEC_EVENT_STATE_CHANGE - log_addr_mask=0010 phys_addr=1000
2021-09-26 22:40:00.928 T:767 DEBUG : CecLogMessage - changing physical address to 1000

Log file:

What I have identified that if I wait until more time, then the long file name scrolling from left to right will stop and if I switch off the TV then the wake up maybe not happening or happens only very longer time.

But with the above example I was not waiting until the scrolling finished, so turned the TV off earlier and wakeup happend and I’ve seen the scrolling finished very soon. Maybe it has no connection to the problem maybe has, Have no clue.
In the log at the begining you will see another trial about watching the same episode then turn off, wait, but it was not waken up “soon” enough, so I did it again and was not waiting as much as I wrote it above. Maybe what could help that I do not use that view of films, episodes which has the thumbnails (library view maybe?) but the file view I’m using, where I going across the folders and select the right file.

hope this log will help more to you.



is there any update on this?



any update on this, or there is no solution?


No idea – sorry.

Hi Sam,

It seems that I found a solution/workaround for the problem. To be honest I do not know how it is connecting to the problem, whether this would be a solution only for the latest update, has no real time to try with previous version. I get a loan a Chromcast with google tv and there is kodi app too. I tried it out and the problem had not occurred there. I checked the settings and there was a big difference, here’s my knowledge is not enough to know what does it really mean, and how it is connecting to the problem: refresh rate: my original setup was always 60, but if I changed it to 59.94 then the problem disappear. I do not know where I should know this value for my TV, why chromecast identify it with right value and osmc doesn’t, but it seems my TV has not siwtched on unintentionaly/automatically. Additional information, if I let the value on 60, then TV turns on randomly.


Have you tried with the latest update to see if anything has improved?

Hi, yes I tried it with the latets update, but unfortunately today TV started to turn on again. So it had no connection to the refresh rate… the problem still exists.

I’m not sure what is going on here either from looking at the last logs posted. I see the TV powering off and them after some time back on again. What I don’t see is Kodi sending anything over CEC to trigger this. I did notice that the RPi is acting as CEC device type 4 instead of the usual type 1. I don’t know how this could be without someone manually editing Kodi’s CEC config file. Regardless, I don’t see how that could be related to the TV turning on.

I don’t think that it is beyond the realm of possibilities that that maybe a bad cable or less than completely stable power connection could be making the TV think there was a device reconnection. There is a couple options in your TV menu for controlling power via CEC ( Standby Power Save, and Intelligent Auto Standby) and it may be worth trying turning one, or both of those options off to see if that gets you working better.

The final thing I can think of is if you have some light source that may be reaching the ir sensor on your TV and just so happens to correspond to a remote trigger. I’m sure it probably sounds unbelievable but it has been known to happen. Probably the quick and dirty test for that is to just put a piece of opaque tape or similar over the TV’s senser and make sure it is blocking well enough your remote no longer works. Once you have that then turn off the TV and see if it turns back on.


thanks for your comments. What the problem is with all the above mentioned (maybe theoretical usecases, light on the remote control :slight_smile:, I liked that ) that on the previous version of kodi/osmc it had not been occurred and when I install again the previous osmc version on a separate sd card the problem does not occur again, only since the newest version.


can you help me what does this CEC type 4 vs 1 means? where I should change? I give a trial for it, I do not changed any cec setting manually I was only setting CEC entries from menu. If I disable CEC then problem does not occur, of course I can’t use my TV remote. I tried the other settings on my TV you suggested but did not help.

I will give a trial of the undervoltage problem because from the log I see more time this under voltage problem then on previous version, could it be that the power consumption of the newest osmc is higher the previous had? But let’s suppose this is the problem it turns TV on only if CEC enabled. But what is the right parameter for a power source? On the RPI there is an external HDD but it has its’s own power source. And there is nothing else on RPI 3b+, direct internet, external HDD with its own power source and nothing else.

thanks and regards


You never should have a under voltage message. Get a proper Raspberry Power Supply

Are you running the most up to date version of OSMC? There was a config.txt option for ignoring CEC that was missing originally from the last big update but it is back with the most current stable release.

That comment was more for just pointing out an anomaly in case it was relevant for one of the devs. I really don’t see how it would factor into the TV turning back on. But to answer the question anyway, in the CEC protocol their are numbers that correspond to what type of device (TV, player 1, player 2, recorder 1, amplifier, etc). Normally what happens with CEC initialization is the OSMC device tells the TV it is recorder 1, and unless there happens to already be a device on the bus using that designation that is what it becomes. In the absence of having two other CEC capable devices connected that are also designated as recorders, and absent it being manually changed to report itself as a player by editing the CEC config file in Kodi’s userdata (since that option is not exposed in the Kodi UI), I would assume it is the TV itself saying no to Kodi designating itself as a recorder and telling it to be a player instead. Is this a problem? No, because Kodi acts the same way regardless of which is set.


I’ve replaced the power supply, which is working fine, but have not solved the problem, still the TV wakes up randomly.

Where can I find this cec releated config.txt and what are the values for I could maintain? Is there a docu about it?


You you ssh into your RPi and run “cat /boot/config.txt” at the terminal you should see the following. The setting in question is “hdmi_ignore_cec_init=1”. Further information on this setting can be found from the Raspberry Pi foundations web site or just with a general web search.

osmc@JohnBedroom:~$ cat /boot/config.txt
# Warning: do not edit this file, or it could prevent your OSMC system from starting.
# If you wish to make changes, you should do so via My OSMC or edit the config-user.txt file in this directory

# Any changes that you make here will be overwritten as this file is managed by the OSMC via the update system


include config-user.txt