TV Turning on

Hey guys,
Just wondering if you would be able to help out with a small issue.
Firstly I would like to say that the OSMC Vero 4k+ is the greatest media player with the most incredible software features I have ever seen. On onto the issue:
I believe the device keeps turning on my connected TV, although the strange thing is that the CEC setting has been completely disabled.
Now I did have this issue before but I had to reset my OSCM for another reason and have forgotten how I had fixed the issue the first time.
I have also looked on the native TV settings for a similar setting to CEC but could not find anything.

Unsure where to go from here, anyone have any suggestions or ideas?

Many thanks in advance!!
:slight_smile:
PS, I’m a technicalogical noob

Are you saying you disabled CEC after you did the OSMC reset or you need to know where to do that?

After the reset I went and disabled CEC,

Maybe try to activate it again and just disable the active source switch

Hi fzinken,
I couldn’t actually find a option called “active source switch” or anything similar…

Well sorry for using a descriptive way instead of the exact menu entry which is Switch source to this device on startup, Wake devices when deactivating the screensaver and possibly Force AVR to wake up when Kodi is activated

Ohh I see them now. Sorry I’m not the most technologically minded :joy:
I’ve set this up, will report back with findings latter on.
Many Thanks!

So I can say for certain that the above hasn’t worked either. Any other solutions guys?

Well enabling debug logging (with CEC details) and check if it is actually a CEC command that causes it.

With enabled debug logs you can run a tail -f on the kodi.log via ssh to monitor.

What is the make and model of your TV? What is plugged into it besides the Vero?

As far as the Vero side goes if you have the CEC adapter option “Enabled” in the off/disabled state I highly doubt this is coming from the Vero, but to be sure the best course would be to unplug the hdmi cable from the Vero and see if the issue remains.

I’ll have to google how to do this and get back to you tomorrow. :slight_smile:

Hi darwindesign,
The TV is a: panasonic Viera, TH-L42E30A. Nothing else plugged into the TV except the audio receiver, but this wouldn’t be the cause. That’s a good idea! I’ll take out the Vero and report back after a two days. :+1:

CEC is called Vieralink by Panasonic. You can find the settings about it turning the TV on in the manual…

https://www.manualslib.com/manual/800753/Panasonic-Viera-Th-L32e30a.html?page=71#manual

I wouldn’t be surprised if there was something odd with the TV and receiver. It could also be the feature that allows the TV to be controlled by a phone/tablet. I had a odd thing where when I turned my TV off, it would turn back on, which would turn my AVR on, and then it would turn off, which would turn my AVR off. It would only do this sometimes normally at night. Once I disabled the option on my TV to power on by a phone/tablet (which it was never setup with) that stopped happening.

No need to google, below comes the info how to enable debug logging including all verbose logging (just enable the on eon libcec).
Then login via ssh and run tail -f .kodi/temp/kodi.log | grep -i CEC thtat should give you details about CEC interaction.

Remember to disable the debug logging afterwards.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

hey guys,
sorry for the late reply! turns out all it was was Panasonics’ setting called “Vieralink”. turned this off and all the issues went away!! thanks, everyone for all your help and time!!

Vieralink is the Panasonic brand for CEC.

I have the same Issue and i don’t think desactivating something on TV side is the solution.

When CEC is disabled on the vero there should not be a CEC signal sent to the TV.

I said that because we might want to let CEC enabled on the TV for the wife being able to control the AV sound trhough the TV when watching television and so on

If you disable CEC on the Vero we won’t send a signal

Sam

When you say disable CEC on the vero do you mean trough the kodi gui and CEC ADAPTER ---->disable ?

Yep.