Tvheadend muxes failing help needed

hey guys, i really need some big help quickly, i’ve got lots of films i want to record tonight on multiple country channels and i really don’t want to miss them, it’ll be a hassle to re schedule them and find out when they repeat again. So, basically. yesterday i set up tvheadend with osmc on my raspberry pi 3 and it worked brilliantly! I recorded prime time Fox NL , first two eps of american horror story season 6 and i watched the recording amazingly the next day[today]! but today, i deleted the iptv channels, excellentiptv.com they came from, i deleted them because my free trail ended. and i tried to add some channels from necroiptv.com . they pended on the mix page and then just failed, and went into idle state. every channel i tried, every time failed. I even reinstalled the whole of osmc on the raspberry pi just now and still, added the muxes to the iptv network failed, absolutely failed! i’ll attach screenshots and logs, i really need some big help. thanks.

There’s a guide here: There is no helpdesk here!

Are you sure you set everything correctly?

that isn’t for tvheadend though, is it?

with tvheadend it doesn’t accept bundled .m3u files, each channel has to be entered in separately.

Can’t you just use IPTV Simple Client? It should allow recording IIRC.

it allows recording?! the only reason i was using tvheadend is because i thought it was the only add-on that allowed recording. do you know how to record on iptv simple client?

and what do you mean IIRC

Not the normal iptv simple client, but this fork should allow recording: GitHub - simphax/pvr.iptvsimple: Kodi's IPTV Simple client addon

You need to compile it though.

IIRC means “If I Recall Correctly”.