TVheadend suddenly not working

Unfortunately my TVHeadend has stopped working. Just stopped working today when I restarted the raspberry pi. Here is the log file:

Also, here is the journalctl file:

I’m using the Raspberry pi 3. using osmc 2017.08-01. no other updates were available.
any ideas? thanks!

18:13:29.789 T:1958785024    INFO: CheckIdle - Closing session to (easy=0x63fed990, multi=0x642037c8)
18:13:36.811 T:1554703344   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - new connection requested
18:13:36.812 T:1554703344   ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to

There is some reason why your TVH client is not found at You should probably dig into your TVH web config to try to figure out why. Kodi is trying.

Second, you have a corrupted texture db -
18:13:18.048 T:1750070256 ERROR: SQL: [Textures13.db] The database disk image is malformed
Easiest thing to do there is simply delete it and allow Kodi to rebuild it.

And third, if this is actually a Pi3, you are underclocking it. Revert from turbo back to normal in MyOSMC. The overclock presets have not yet be optimized for Pi3.

thanks for the reply! I did try previously to check my web config for TVH but unfortunately however I am unable to log into the TVH web config. The site can’t be reached from the web browser since this happened.
regarding the textures13.db file, what info am i losing if i delete it?
thank you.

Thumbnail images. They will be re-populated afterwards.

thanks. any ideas regarding getting the web interface working so that I can fix this?

Check your Tvheadend HTSP Client setting!

Assuming you have the OSMC skin active with English language then in the OSMC GUI go to

Settings -> Add-on browser -> MY-add ons -> PVR Clients -> Tvheadend HTSP Client -> Configure
In the Connection Settings you should see

  • IP:
  • HTTP: 9981
  • HTSP: 9982
  • user: osmc
  • password: osmc
  • conn timeout: 10
  • resp timeout: 5

in your second log you see the most possible root cause:

Sep 26 16:41:40 osmc systemd[1]: tvheadend.service: control process exited, code=exited status=78
Sep 26 16:41:40 osmc systemd[1]: Failed to start TVHeadend Server.
Sep 26 16:41:40 osmc systemd[1]: Unit tvheadend.service entered failed state.

Perhaps sudo systemctl status tvheadend -l gives you more information about it.
I would simply try to deinstall TVHeadend Server in the My OSMC -> App Store and reinstall it afterwards, just to be sure.

Thanks for your replies. Unfortunately I have run into a snag.
I uninstalled TVheadend server. when i reinstalled it, i received an error. Here is the Journalctl log.

Here is results from sudo systemctl status tvheadend -l

  • tvheadend.service - TVHeadend Server
    Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled)
    Active: activating (start-pre) since Wed 2017-09-27 14:42:48 EDT; 4s ago
    Process: 1760 ExecStart=/usr/bin/tvheadend -f -p /run/ -C -u osmc -g video (code=exited, status=78)
    Control: 1762 (sleep)
    CGroup: /system.slice/tvheadend.service
    -control -1762 /bin/sleep 10

Any ideas? thanks again.

Only idea I have is to completely get rid off the old TVHeadend config and start from a virgin one:

  • disable the Tvheadend HTSP CLient (see my post above how to locate this)
  • uninstall TVHeadend Server from within the MyOSMC - App Store
  • reboot the device
  • login via SSH and rename the directory /home/osmc/.hts/tvheadend to something like /home/osmc/.hts/tvheadend.old
  • install TVHeadend Server again
  • first reconfigure Tvheadend HTSP CLient to defaults in Connection Settings, Streaming Settings, Timer Settings and Advanced Settings
  • Enable the Tvheadend HTSP CLient
  • configure the Connection Settings of the Tveadend HTSP Client to use osmc/osmc as user/password
  • reboot the OSMC device

With that you should have a virgin TVheadend + Tvheadend HSTP Client stack on OSMC.

Means tvheadend cannot lock the config file.

Try sudo chown -R osmc:osmc ~/.hts

Thanks everyone for your help. Unfortunately prior to trying the easy route that Sam provided, I used Jim’s to basically start TVheadend from scratch. After reinstalling TVheadend, I copied over a lot of the files from the old folder to the new TVheadend folder in order to save me configuration time and to get it to how it worked previously. after some work, i believe it is working properly again. thanks again to all who assisted.

Hi Sam, I’ve recently been having trouble with my TVH setup. Taking a very long time to stop/start or restart the service. Currently on 2018.03-2. TVH was at 4.2.4, but taking the above advice I uninstalled/rebooted/reinstalled TVH. Now version is 4.2.6.

Same thing was happening where the service wouldn’t stop properly:
Apr 30 18:49:37 basement systemd[1]: Stopping TVHeadend Server…
Apr 30 18:51:07 basement systemd[1]: tvheadend.service: State ‘stop-sigterm’ timed out. Killing.
Apr 30 18:51:07 basement systemd[1]: tvheadend.service: Killing process 3260 (tvheadend) with signal SIGKILL.
Apr 30 18:52:37 basement systemd[1]: tvheadend.service: Processes still around after SIGKILL. Ignoring.
Apr 30 18:54:07 basement systemd[1]: tvheadend.service: State ‘stop-final-sigterm’ timed out. Killing.
Apr 30 18:54:07 basement systemd[1]: tvheadend.service: Killing process 3260 (tvheadend) with signal SIGKILL.

I realized that the issue in my case (and maybe others) is that the user:group has maybe changed:
ExecStart=/usr/bin/tvheadend -f -p /run/ -C -u osmc -g video (code=exited, status=0/SUCCESS)

I performed your ‘chown -R osmc:osmc ~/.hts’ suggestion and almost immediately it recovered. It looks like recently this may have changed from osmc:osmc to osmc:video.

Something to investigate it seems.


@osmc47 Here all works with group video on several devices. Just to be sure: What is the content of

sudo grep video /etc/group


sudo cat /lib/systemd/system/tvheadend.service

on your Pi?

Stopping tvheadend and give them all osmc:video ownership let’s you reproduce the issue?

Hey JimKnopf, here is the output you requested:

osmc@basement:~$ sudo cat /etc/group|grep video

osmc@basement:~$ sudo cat /lib/systemd/system/tvheadend.service 
Description=TVHeadend Server

ExecStartPre=/bin/sleep 10
ExecStart=/usr/bin/tvheadend -f -p /run/ -C -u osmc -g video
ExecStop=/bin/rm /run/


I would like to note last night I updated to the was 2018 April update. The system was hung on trying to stop the pid associated with TVH - took about 5mins. Update worked ok.

Stopping the TVH service was normal this time. I changed the user: group to osmc:video as you suggested and started the service. It started normally. So to answer you’re question I could not repro my issue post update. To me that means there was some compatibility issue between TVH 4.2.4 & 4.2.6 and/or March/April 2018 Osmc update.

Strange, anyway good to hear that your Pi returned to normal operation. Thx for your time.

Thanks for your help JimKnopf!