UHD playback very jerky

Hi all. Long time user of the 4K (not +) model, just updated to the latest version after finding the interface had gotten very sluggish.

This isn’t the issue, but mentioning for info in case relevant. I was using the Scope Nox skin as I have a fixed widescreen display, but it isn’t compatible with the latest software so have dropped back to OSMC skin.

However, UHD playback has pretty much died. I can get the image, but it is very jerky, either refreshes every 5-8 seconds, or just freezes. Sound is fine.

I didn’t have an issue pre-update, have a usb gigabit adapter, and am wired to an unmanaged gigabit switch connected direct to my router. Nothing has changed apart from the software update.

Any ideas?

EDIT: Just tried a few files and now get a ‘buffering’ message while paused, then a few seconds, then repeat

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks - logs uploaded, link as follows:


Watching the info at the top left of the screen while the movie was playing showed the CPU and 1/2/3/4 indicators maxing out at 100% repeatedly.

The log is blank – can you upload all logs?

Apologies. Should be fixed now:


Note there seems to be a space between the .tv/ and the ‘iruy’ I have ignored

I have just checked and hardware acceleration was turned off. Turned on and it improved things somewhat.

That was my guess from 100% CPU usage.

Please post another debug log if you still get stutters.

1 Like