Unable to access SMB shares since last update

Hey there,

Since the latest update (dec 2015), I’ve been unable to access any of my SMB shares. This is OSMC running on a RPI 2. The files are hosted on a Windows 10 computer. I’m able to see the network location of the shares but when I try to open them (under video -> files), I get a login prompt. When I type in the correct password (I’m using an outlook account to log in to the windows 10 computer, which has been working fine up til now), the dialogue box stays in place and “Enter password” turns red, indicating that I should fill in the password.

OSMC has been working flawlessly up until this point. I’m using the smb://192.168.x.x/sharename notation. I’ve tried:

  • Leaving the password screen blank
  • Rebooting OSMC
  • Re-adding the share

Hoping you guys have any other ideas. Thanks in advance!

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Sorry, thought the information I provided would have been enough.

The issue you are currently experiencing with OSMC
I’m unable to access my SMB shares
What you were doing when this issue occurred
I had just rebooted after getting the latest update when I tried to play a movie, and it didn’t work. I then checked the SMB share, and I was unable to access it. I tried filling in the password, and it didn’t work.
Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.
I can reproduce it by trying to play the movie again.
The device you are currently running OSMC on
Raspberry Pi model 2b
What peripherals are attached to the device?
None at the moment.
Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?
Yes, it’s happened right after the latest update. Before that, everything was working fine.

I miiight just have posted too quickly here. Seems that for some reason, when I use the first 5 characters of the full account name, combined with the password, everything works fine again. No idea why.

Anyway, just leaving this here for someone who might encounter the same problem in the future. Thanks for the help offer anyway!

I have the EXACT same problem. I have 3 pi’s, 2 of which are still on the older versions. I’ve never had this problem before, now that I have updated on the one pi, I can’t use SMB. Like I said, exact same problem. My server is not password protected, so the fix that worked for you does not work for me.

Any assistance would be greatly appreciated.

Surely that is going to be an issue on your windows server ?

If sending only the first 5 characters of your username is enough to get a connection there is no way that can be a client side thing - it must be at the server side, as its the server that authorises the connection. The client can’t “trick” the server into allowing a connection with a partial username or password. :wink:

Well, I got the “partial” username by checking the Event Viewer, so it’s not entirely random. Checked C:/Users after, which showed me the same username, corresponding to the first 5 characters of the outlook address (it seems to do that with every e-mail address btw, I have another one on the same PC where it has the first 5 characters as the user name). I got it to work by using that user name.

Thing is - I didn’t change anything on the server side of things - just updated the RPI OSMC and got the error right after. Is it possible that in the new version, @-signs aren’t recognized as valid characters in a username anymore or anything like that?

It’s all fixed for me now anyway, but if you need any extra information or if you’d like me to run some additional tests just let me know. It’s the least I can do for you guys for putting in all the hard work. Thanks!