Unable to boot Vero

I received the vero a few days ago working perfectly fine but now it won’t boot. I’ve reinstalled hte image onto the SD card a few times and still no success.

When powering it on the red light of the SPDIF doesn’t seem to flash and from looking at the back of it there is a tiny LED light that is constantly on. I’ve also used different laptops (Windows) to re-install the image to the sd card and a gparted live cd and dd’d the image file directly to the SD Card.

My TV connected via HDMI detects something is at the other end, but just shows a black screen with ‘no signal’ rather than ‘check signal cable’ - which id does when the vero is powered off.

Is it still likely to be a problem booting of the SD Card?


Can you let me know how you tried to load the image on the SD card?


Hi Sam

I originally used the Windows executable published on the website, from two different machines and then tried grabbing the image file directly from the downloads site and using ‘dd’ on a linux machine to extract it onto the SD card.


I would suggest trying another SD card. Failing this – you will probably want to RMA the device.

The SPDIF should be red on the side and then turn off once the bootloader has loaded.