Unable to build menu error

Hi All,

I have just updated my OSMC via SSH because it wasn’t able to update via the UI since december.
However, after the completed update some of the menus are missing, or not working as normal, and after a few second OSMC tries to build the menu, and I get “Unable to build menu - please submit log…”

Any tips?

The log:

I tried to update via the UI, and I now received an unknown error and unhappy face.
Looks like something more is wrong :frowning:
The new log:


  1. I would take out the overclocking to ensure that is not part of the issue

  2. Either your SD card is dying or your database upgrade has nit worked (maybe you didn’t wait long enough). Maybe try to delete all the new databases and reboot. Hopefully the upgrade works then.

11:29:05 27.719259 T:3024331312 NOTICE: Attempting to update the database MyVideos99 from version 93 to 99
11:29:06 28.428232 T:3024331312 ERROR: SQL: [MyVideos99.db] The database disk image is malformed

Thanks for the suggestions!

When I check the version number in the OSMC menu, it’s updated as of latest version.
I deleted the libraries and ran the indexing again - is working now and no error message.

So looks like I am out of the woods until next update - I can’t really remember having a smooth experience when updating:(

But thanks:)

If you get any errors relating to “unable to build menus” and you find some of your menus are missing, look in the directory /home/osmc/.kodi/userdata/addon_data/script.skinshortcuts/ and delete any files you find there such as skin.osmc.hash then reboot. This will force the menus to be rebuilt again.

There is a bug in script.skinshortcuts that is used by the OSMC skin (among other skins) that occasionally causes it to fail to rebuild the menus after a Kodi update.