Unable to download subtitles in any add-on

For a few weeks now I have been unable to download subtitles. It gets stuck at “Searching for subtitles…”.
I have tried several add-ons, for instance open subtitles, subscene and undertexter.se.

The debug log for this issue is available here: https://pastebin.com/zkLQTdEL

Log snippets, especially ones posted on third party sites are not proper logs. We have a guide that explains proper procedures here…

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

As for your issue are you sure you are running the most current versions of these add-ons and that you have proper credentials entered into the the subtitle add-on’s settings? I just checked open subtitles on my system and it seems to be working fine.

Sorry, I didn’t see the logging procedure.
However, as I was going through that part the subtitle searching somehow magically started working again.

I rebooted the Vero 4K+ I’m using to see if that would help right before posting here. It didn’t immediately make a difference, but I guess something got updated or something since it just works now (I had already made sure the addons were updated before restarting).

So I guess this is solved. :slight_smile:

Hi. I am having same problem except that nothing “magically” started working again, and I therefore, cannot download subs. OSMC gets stuck and I have to give up and change movie. All is updated and well connected. Any ideas apart from magic? Thank you

It is kind of hard to say what your issue is as we don’t know what subtitle add-on your trying to use, the name of the file, or logs that would show us something. If you had something that was working and then stopped, then you may want to either check that the web site it is sourcing from is not down or check the relevant thread for that add-on on Kodi’s forum to see if there is any known issues being reported.

1 Like

Hi. I found out that changing skin to Kodi’s skin, the subs download works fine. In any other skins it doesn’t. ???

By “Kodi’s skin” you mean Estuary? If you switch to the OSMC skin it no longer works? If you would like to provide debug logs that show the sub downloader failing it may allow us to see what is going on. That particular condition is not a known issue that I am aware of.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/