Unable to enable <extractthumb>

Thumbnails for video files are not loading. Tried enabling in guisettings and restarting Kodi. It reverts back to disabled.

Does it revert back after a reboot?
Try ‘Exit’ instead of reboot after making the change. When Kodi comes back up, it should remain enabled.

Otherwise, debug log is needed to know what the problem is and maybe a short video.



I used the command systemctl restart mediacenter previously.

I manually go into guisettings and change this line false to true

I just tried exit and then went back into guisettings and false again

I tried deleting this line complete. Upon Kodi coming back up the line false is back again

I will try and get a debug log posted

Try exit Kodi instead.
I also recommend you make system settings changes via Kodi instead of editing the file. If you don’t stop Kodi first, the changes are likely being overwritten. This is expected behaviour.

I tried making the changes within Kodi and that makes no difference. I tried this first and then start editing the guisettings file after that failed.

I have stop kodi and made the changes then started kodi and it reverts back.

I have tried exit from within Kodi still the same behaviour

Extract thumbnails and video information is toggled in the kodi settings

It may be better for you to wait for the update where we have hopefully resolved the issue with settings being reset on reboot.

Unfortunately I didn’t get many tests so can’t confirm if it’s resolved, but I’d advise for you to wait for the update, and if it still persists, we’ll then investigate further.

The update should land soon: just building Kodi v17.1 now.



Thanks Sam appreciate it. I will let you know after the update if the issue persists


Still no change. I can not get true to work or stick.

Video files still just show the default no thumbnail image.

I go through settings and toggle “Extract Thumbnails and video information” and still no change in behaviour or in guisettings. I Toggle on and off doesn’t change anything. In fact the lines

    <extractchapterthumbs default="true">true</extractchapterthumbs>          
    <extractflags default="true">true</extractflags>                          
    <extractthumb default="true">false</extractthumb> 

Do not change no matter what I do.

On Vero 4K, we have this patch, copied over from other platforms. It’s not really needed on Vero 4K, as there’s enough performance to extract thumbs for most sized folders.

From fb2e5cd366c5830b9f8f442606074fa3342bad0b Mon Sep 17 00:00:00 2001
From: Sam Nazarko <email@samnazarko.co.uk>
Date: Tue, 2 Jun 2015 22:16:09 +0100
Subject: [PATCH] Disable thumbnail extraction by default on low power

Signed-off-by: Sam Nazarko <email@samnazarko.co.uk>
 system/settings/settings.xml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/system/settings/settings.xml b/system/settings/settings.xml
index d7ef609..574621d 100644
--- a/system/settings/settings.xml
+++ b/system/settings/settings.xml
@@ -979,7 +979,7 @@
         <setting id="myvideos.extractthumb" type="boolean" label="20433" help="36180">
-          <default>true</default>
+          <default>false</default>
           <control type="toggle" />
         <setting id="myvideos.extractchapterthumbs" type="boolean" label="37044" help="37045">

But you should still be able to adjust the setting via the GUI.


Yeah for what ever reason it doesn’t adjust it in the gui. I went and edited the /usr/local/kodi/system/settings/settings.xml and changed it there. Now the guisettings.xml will keep the change by editing it manually. Through the gui no such luck

That may be a recent Kodi bug – as that patch has existed on other platforms for a while now.

Let’s keep an eye on it but glad it’s working now.