Unable to watch via CVBS


I’ve tried to prepare my vero4k to work in our holiday, where we only have an old tube TV with Scart connector.

So, ordered an adapter from OMTP to CTIA AHJ to swap Ground & Video.

I’ve tested the cable and it works as expected.

Then I entered the command to swicht to CVBS:

sudo fw_setenv hdmimode 576cvbs

After reboot I have correct Stereo sound , but a completely distorted image.

You can see a part of the Kodi menu, the red frame says: Videos,
so on hardware side, all seems fine.

Any ideas, how to get a clear image?

Works here OK on a LCD screen through SCART and composite. Can you upload some logs right after a reboot?

A thought: does your TV have a setting for S-Video through SCART? Then it should be off.

Here is the dmesg output.
I think, there are more relevant infos.

Glad you’ve done that.
Have you used CVBS on the device before?

Do you see anything like the Please Stand By or OSMC logo?


Yes, the first time.
I tried on two different TV.
Yes, there is the logo:

No S-Video.
My AV-Receiver also has a simple Video-out for the settings… that one is working.

Is there a manual for the TV on-line?

It’s not so old as to have a user ‘horizonal hold’ control?

Or perhaps a setting for +ve/-ve sync?

Yes, go to Panasonic,
Enter TX-P42STW50in Eingabe Modellnummer
to get the Manual.

So the image above is not from the ‘tube TV’ you want to use on holiday?

Do you have the SCART input set to VIDEO here:

Betätigen Sie den Indikator zum Umschalten zwischen [COMPONENT] und [VIDEO] in [AV2] durch Drücken der linken oder rechten Cursortaste

No, we will go there in two weeks.
This is the Plasma I’ve linked above.
An other test on a LG LED brings me only a ‘No Signal’

I Have an old tube here,
but it is installed and I’m not able to reach the connectors :wink:
I mean, I need help to move the nearly 180 lb peace of TV

Perhaps I can test it this weekend

This is for AV2… SCART is AV1.
But I also tried AV2, of course. (with the ‘video’ selected).
The same result :frowning:

Do you have a link to the cable you are using?

Ah yes. SCART is supposed to be automatic. I can’t see what sort of connector AV2 is - RCA sockets?

Edit: yes, found it!


Same adapter as mine.

Probably stupid – but can you try 480i?

Do you mean
sudo fw_setenv hdmimode 480i ?


Shouldn’t that be 480cvbs?

Yep – skimmed that.

Tested both… and a few more… nothing.

Have a look at the fw_printenv,
line 11 - 18 & 71 + 72.