Unconsistent CD mount - can't play cd


Sorry if I’m too noob to understand this but I just added an external usb BR/dvd/vd player to my Rpi2.

This player is attached to a self powered usb hub (one 2A power) , with the 1TB HDD that has been working since the beginning.
the Pi itself is also powered by its own power (2A). and its embeded usb ports are used for 1 wifi dongle, kd + mouse.

The first time I started with the BR connected I’m not sure what I was supposed to see, but inserting a CD I saw a new ‘disc’ first level menu in Confluence and was able to play it, or changing the default behavior in system to rip it correctly.

However I never been able to eject it I had to reboot and press the physical button of the player to open the tray during the ‘black screen’.

I tried then with another cd but nothing happened this time except I heard it trying to play but failed. no menu, no playing.
Unable to eject it, reboot. (this cd is ok on my pc)

during those reboots I lost the 1TB HDD a couple of time (?) and it came back as soon as I unplugged the BD drive…

Now both Drives seams to be powered but the Cd does not play, it does some starting scan or I don’t know what, then its led switches off and nothing happens anymore, but I can eject it, meaning it is not mounted at all.

Thank for your help

CC @DBMandrake

If you lost the 1TB hard drive and it came back when you unplugged the BD drive then you have a lack of power issue. You say you have a “self powered usb hub”, do you mean one with it’s own power adaptor ?

As for the other issues, we are aware of some intermittent behaviour of automounting disks that some people are seeing, we are working on rewriting the whole automounter system, hopefully in time for the next monthly update.

However I don’t know without seeing a kodi debug log and system journal demonstrating the problems that you are in fact seeing an issue that we are aware of or whether something else is going on.

You should always be able to eject a dvd provided that no program has locked the mounted directory - eg if you were to cd into the directory (thus locking it) you would not be able to eject the disk no matter how many times you press the button - this is normal behaviour.

Another thing that would stop it being ejected is a user accessing a share pointing to that disk shared by samba. Sometimes windows clients will not “let go” of a share even after you close all explorer windows. That too would prevent it being ejected.

Thank you

“self powered usb hub”, do you mean one with it’s own power adaptor ? "
Yes 5V/2A same spec as the other power adapter used on the Rpi.

But the lost of the 1Tb hdd only happened once.

Regarding the main issue (now the CD/DVD/BR player is never ‘activated’) I would not say it’s intermittent behavior because it only worked one time (the first time, well and a second after I changed the default CD insertion behavior to ‘rip’). For those 2 times the Cd was played and then ripped correctly to Flac.

To eject a cd …I don’t understand. I agree with the fact if any process is using it, then it’s locked… but once the cd has been played or ripped do I wont be able to eject it ?.. (I do not had any ssh positioned on it ).
Then, is there a menu to manage the ejection ?? (if, at least the DISC menu appears, which is not my case now).

I was not able to see where the CD was mounted ( nothing in /media/ execpt the M3-ntfs 1TB hdd), but I’ll check again this point.