Unhandled Exception Error in OSMC App (MySQL Settings)

Hi,
I updated my NAS a few days ago and it changed the bind adress of my mysql server back to 127.0.0.1. I didnt notice this right away and thought it was related to my vero4k and tried to reconfigure mysql through the osmc app again.

Doing this i noticed an Error when enabling the “import watched state” Option in the app and it would not save or accept my settings. After enabling debug log i got this:

DEBUG: Unhandled Exception thrown in Networking GUI
                Traceback (most recent call last):
                  File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py", line 413, in onClick
                    self.shutdown_process()
                  File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py", line 427, in shutdown_process
                    self.read_mysql_settings(self.advs_dict)
                  File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py", line 761, in read_mysql_settings
                    sub_dict['videolibrary']['importwatchedstate'] = 'true'
                TypeError: 'NoneType' object does not support item assignment

Keeping this option unchecked works fine and it connected to my server (after fixing the bind adress) fine again, alle movies, shows and files still had the correct watched state.

Is this a bug in the “myOSMC” app/addon or with my server?
This was a bit frustrating as i suspected it was a connection problem (which was there as well) but it still showed up after i fixed this. The myOSMC app did not give any information.
Yes i know i should have checked the logs first ; ) but if its a global osmc (vero, pi etc) bug i just wanted to report this.

OSMC is the distribution build on Debian Stretch. Kodi is the application included with OSMC.

But your problem is actually a bug in the MyOSMC addon. I fixed this a month ago, so not sure why it’s back. I’ll take a look at it.

I meant this is probably a “global” osmc only problem as it is related to the myosmc app and not a kodi one. anyway thanks for checking it.

i updated to the latest update a few days ago when it showed up, so i should be on the latest official release for the vero 4k

I need to look at this closer, it is not the exact same problem that I fixed before, but very similar. Thanks for letting us know about it.

no problem, glad i can help.
If i can test anything i would not mind, but i guess this can be reproduced with any system :slight_smile:

I have the same problem, happy to test a solution. Only happens on my Pi 3B+, it’s OK on my Vero 4K. All running latest software version.

I am having the same problem. I have Kodi/Mysql set up on 2 devices (Windows desktop and Mac laptop) and it all works as advertised. But I keep getting the same (unhandled exception) error when I try to enable Mysql support on my Raspberry Pi 3B+. Any updates?

Hi,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Tom.

Hi, thanks for the quick reply.

I did as you requested.

  1. Turned on debug logging
  2. Rebooted the device
  3. Reproduced the problem
  4. Uploaded the log using the OSMC GUI.
  5. I think this is the URL you asked for - https://paste.osmc.twf

I have described the problem in my prior post and am not sure I can provide any additional detail. It would be nice to use MYSQL - just tell me what I’m doing wrong and I will address.

Thanks again.

Mike

Please paste the link to your logs again. The link you gave does not work.

I’m having my share of troubles here.

i created a new set of logs and uploaded them via the GUI. It gave me the following URL - https://paste.osmc.tv/ehedalatid. But when I went to your paste site, I couldn’t find a file by that name.

So I used my Mac to ssh into my device. Sent the logs via the “grab-logs” command. It gave me a different url - https://past.osmc.tv/. Nothing there either.

So I hope the developers got what I uploaded, but i cannot seem to find/send a url that makes any sense …

Sorry

That would indicate something serious wrong with your device.
Did you restarted twice before you tried to upload the logs?

Try alternative cat /home/osmc/.kodi/temp/kodi.log | paste-log

No, I only restarted it once … will try that. Will also try your alternative. Thx