Update Error on Pi1

Help!
After updating this (from the prompt) on my Pi1, it won’t run but goes to a dos/command prompt, asking me to log in.
I used osmc for both username and password and got a message about T&C and IP, followed by this prompt:

c@osmc:"$ (cursor is here)

We’ll need a bit more information than that…

What exactly did you do to update ? Can you get a screenshot of the problem ?

You could try booting with CTRL and SHIFT held down together until you see the blue update screen, that should attempt to update and therefore finish off any partially completed update.

Sure (and thanks).

After rebooting, I was presented with a prompt to install an OSMC update, which I clicked OK/yes to. After that completed (I didn’t watch it), the screen was blank but with that sad face icon that to me means error.

Touching any button brings up the cmd/dos prompt I described. Logging in brings me the following screen:

https://goo.gl/photos/9Y4VM6VsuRAGGsbh6

I tried your method and it did pull up the OSMC screen but then reverted to this one once I released CTRL+SHIFT.

I’m confused - where did you see a prompt to install updates which had a button to click OK on ? The only one that I’m aware of is within Kodi itself yet you’re saying Kodi is not booting.

If by OSMC screen you mean the blue splash screen with OSMC on it, then you will get that regardless of what keys you hold down.

The picture shows a login prompt which you would get if you held down only CTRL. Please try again and make sure you hold down both SHIFT and CTRL at the same time, and keep holding them down until a blue text screen appears that says checking for updates. (Don’t release when you see OSMC)

I rebooted after it updated some add-ons, and before the OSMC screen appeared, I got a prompt to update OSMC. I dont know what you mean by “in Kodi”, because I’m a novice at all this, but assume that it was in Kodi.

So yes, at that point everything was working fine (by that I mean OSMC was working, although few of my add-ons worked, and I was getting script errors all the time with them). Until the update.

After the update, without me touching or pressing anything, this is what I see:

1 OSMC splash screen
2 Blank screen with sad face icon

  • this just stays and does not go away (is it a screensaver?)
  • if at that stage I touch a cursor key or ESC, it loads the login screen
  • otherwise nothing happens at all

I’m now thinking that I should reflash OSMC, because of this problem and the one I’ve been having with the add-ons. Overall my experience has been substantially worse than it was with RaspBMC.

I’m also wondering if I should go for a different build, as it is a first-generation Pi and I put build three on.

Any thoughts?

Hi,

No – something is wrong here. I would recommend when you get back to the menus, going to My OSMC -> Logs and uploading a full set of logs. If you give us the URL then we can have a look at what the problem is.

Install the image named ‘2015.06-1’.

Sam

Hi.

I did that (installed again from scratch) and it does load the main OSMC interface, and does even play the odd podcast, although most of the Add-ons don’t work at all (eg TED, ESPN3). When I select My OSMC though, it gives me the message: “OSMC Setting Service failed to launch”. This was after it crashed and reverted to that login screen following an attempt to Update the Kodi Add-on repository, which is empty.

Thanks

This sounds like a hardware problem. You should try checking your SD card and power supply

Sam

It’s happening with two different SD cards. What should I check for with the power supply?

Currently the two power supplies (Pi and USB hub) are connected to one two-plug adaptor. They’ve been working fine for ages, but could that be the problem?

Update: I plugged the Pi directly into the wall and the USB hub into another adaptor, which it shares with the TV, router and printer. No effect

Hi

Just wondering if you’d any more thoughts on my query - regarding checking the power supply particularly.

Thanks