Update error

Can I get a help with my update error?
I can update the major versions but get update error message once in a while.

http://paste.osmc.io/opicuvimeb

Well first not related to your update error but nevertheless check your /boot/config.txt you have a broken entry the _mem_1024=256 delete that.

From your apt.log I can not see any error.
But I see you added raspbian sources. I suggest you remove them and do a sudo apt-get update to see if your error goes away with that.

deb http://archive.raspbian.org/raspbian wheezy main contrib non-free
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free

Thank you! Looks like that did the trick. After trying to update manually it does not give an error anymore.