Update Error

my Vero 4K has come up with an update error. I have the January 2020.01-1 update installed.
If I ssh in and try sudo apt-get update I get the following:

Ign:1 Index of /debian stretch InRelease
Hit:2 http://security.debian.org stretch/updates InRelease
Hit:3 Index of /debian stretch-updates InRelease
Hit:4 Index of /debian stretch Release
Ign:5 Index of /osmc/osmc/apt stretch InRelease
Err:6 Index of /osmc/osmc/apt stretch Release
403 Forbidden
Reading package lists… Done
E: The repository ‘http://apt.osmc.tv stretch Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Any help appreciated.

Please try again. It’s working for me.

osmc@osmc:/var/lib/apt/lists$ sudo apt-get update
Ign:1 http://ftp.debian.org/debian stretch InRelease
Hit:3 http://security.debian.org stretch/updates InRelease          
Hit:4 http://deb.debian.org/debian stretch-backports InRelease      
Hit:5 http://ftp.debian.org/debian stretch-updates InRelease        
Hit:6 http://ftp.debian.org/debian stretch Release 
Get:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease [4682 B]         
Get:8 http://ftp.fau.de/osmc/osmc/apt stretch/main armhf Packages [24.8 kB]
Fetched 29.5 kB in 3s (9702 B/s)   
Reading package lists... Done


We need a full a log, please issue:

grab-logs -a

Please post the link here, it will provide your apt history.

Thanks Tom.



Log looks ok, have you tried as @dillthedog suggested?

If still and issue a full log will be required;

grab-logs -A

Thanks Tom.


retrying still throws up the same error.

grab-logs -A gives https://paste.osmc.tv/ so I have no idea where they were uploaded to.

Quick update, I found the error. All I did was comment out the line http://apt.osmc.tv in sources.list and it fixed it.

I’m so used to OSMC updating without errors I was surprised to see one. A quick ask of Mr Google sorted it.

Thanks for your help.

What you have done here is no solution at all, lol… You have now effectively ensured that you will not receive any updates to OSMC/Kodi except for underlying debian updates.

So, what happens when you attempt to connect to http://apt.osmc.tv from the browser of another computer that uses the same gateway to the internet as your Vero?

It redirects to Index of /osmc/osmc/apt

Are you using any non standard networking or DNS configured on your Vero?

No, none at all on Vero or router.

Checked using my mobile network as well and the redirect is the same.

My output matches @dillthedog now so I believe all is correct.

After uncommenting the osmc apt server? If yes, good, seems it was just a temporary inability to connect.

Is BT your internet provider? Is it possible you are affected by this issue?

1 Like

BT is my internet provider but I’ve never had a warning for apt.osmc.tv. I have disabled the web protect service now and still get redirected to ftp.fau.de.

The redirection is correct. It was the 403 Forbidden that was the issue. Another BT customer experienced the same error.

1 Like

I wasn’t getting a 403 error with BT web protect in a browser however I can now confirm that I have restored apt.osmc.tv back to my sources.list and everything works as it should.

It seems that my Vero was getting a 403 but my laptop browser wasn’t. That’s all I can think it could be.
Now that BT web protect is disabled everything works as it should.