Update Issues

Hi there !

I’m new with OSMC, and I have a problem: my OSMC is connected to Internet (on the sys infos, and I’m able to ping google.com), but when I want to use something using Internet on my OSMC, it does not work (addons installation, library scan, etc).

I don’t know where are the logs in OSMC, so tell me if you need it.

Thank you very much for your help,

Best regards,

Tonio.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

As you write that you can ping google.com it seems you know how to ssh into OSMC. What happens if you do sudo apt-get update?

Thank you for your answer.

The apt-get update works normally (all the repos fetched).

Here are the logs.

Thank you again !

22:02:39 21.338261 T:1739961376 ERROR: CCurlFile::FillBuffer - Failed: Couldn’t resolve host name(6)
22:02:39 21.338499 T:1739961376 ERROR: CCurlFile::Open failed with code 0 for http://mirrors.kodi.tv/addons/gotham/addons.xml.md5

Seems to be a problem with your DNS setup. Can you do ping mirrors.kodi.tv and paste the result here

You’re right I’m able to ping google.com, but not mirrors.kodi.tv (it’s stuck at “PING mirrors.kodi.tv (89.16.176.16): 56 data bytes”).

What can I do ?

EDIT: I note that I’m not able to ping it with neither my computer and neither a server I have (not on my network). Is this mirrors.kodi.tv pingable?

Ok, yes mirrors.kodi.tv is not pingable. I just wanted to see that it is resolved correctly which is the case.
So now it is even more strange that you get the error.
Can you install wget sudo apt-get install wget and then execute wget http://mirrors.kodi.tv/addons/gotham/addons.xml.md5

Wget is installed by default - no need to install it. Curl is also installed by default.

Okay, the Wget works perfectly (it’s download the file)

Wasn’t infront of my OSMC and wasn’t sure anymore. Better be safe then sorry :wink:

Ok, now I am getting to the end of tests I have in mind. If also that worked there is no reason why it shouldn’t work from within Kodi.
Just to be sure also curl works can you try curl http://mirrors.kodi.tv/addons/gotham/addons.xml.md5

Then I don’t know if its works. The output of the command with the verbose option:

* Hostname was NOT found in DNS cache
*   Trying 89.16.176.16...
* Connected to mirrors.kodi.tv (89.16.176.16) port 80 (#0)
> GET /addons/gotham/addons.xml.md5 HTTP/1.1
> User-Agent: curl/7.38.0
> Host: mirrors.kodi.tv
> Accept: */*
>
< HTTP/1.1 200 OK
* Server nginx/1.8.0 is not blacklisted
< Server: nginx/1.8.0
< Date: Tue, 22 Sep 2015 17:15:38 GMT
< Content-Type: text/plain; charset=UTF-8
< Content-Length: 44
< Connection: keep-alive
<
* Connection #0 to host mirrors.kodi.tv left intact

If you run curl without the verbose flag you should get the md5 hash been displayed 54cea16d9de3861abd497c5f6d7e9ab0 addons.xml.
But looking at your verbose output it generally looks ok evenso the hash output is missing (maybe you forgot to copy/paste that part).
Which means I am now at the end of my idea of what might be your problem.

Yes you’re right, I forgot the md5 display !

Hi,

I think i have the same problem here. :confused:
can ping google, mirrors.kodi.tv. The osmc can update, upgrade,
but i cant do anything ( install addon, refresh the movie database… nothing.) :triumph:

11:37:47 123810.781250 T:1504703520 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
11:37:47 123810.781250 T:1504703520 ERROR: CCurlFile::Open failed with code 0 for http://mirrors.kodi.tv/addons/gotham/addons.xml.md5
11:37:47 123810.781250 T:1504703520 ERROR: Open - failed to open source http://mirrors.kodi.tv/addons/gotham/addons.xml.md5
11:37:47 123810.781250 T:1504703520 ERROR: Failed to fetch checksum for directory listing http://mirrors.kodi.tv/addons/gotham/addons.xml for repository repository.xbmc.org.
11:37:47 123810.976562 T:1515189280 NOTICE: Thread BackgroundLoader start, auto delete: false
11:47:37 124400.953125 T:1504703520 NOTICE: Thread JobWorker start, auto delete: true

Are you on the latest version of OSMC/Kodi, seems not so. Please provide full debug logs.
To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Maybe it was a temporary problem. Can you try again? Also can you check if you execute on the command line curl http://mirrors.kodi.tv/addons/gotham/addons.xml.md5 what you get (should get a MD5 sum and addons.xml).

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

here is the log : http://paste.osmc.io/hebaxuqehu
I am on the latest version of osmc on raspberry Pi 2.
With the curl http://mirrors.kodi.tv/addons/gotham/addons.xml.md5
i got the md5 sum : > fd9407fb3c1d4d03d53b99e12163653d addons.xml
If i use curl -v http://mirrors.kodi.tv/addons/gotham/addons.xml.md5
i got :

  • Hostname was NOT found in DNS cache
  • Trying 89.16.176.16…
  • Connected to mirrors.kodi.tv (89.16.176.16) port 80 (#0)

GET /addons/gotham/addons.xml.md5 HTTP/1.1
User-Agent: curl/7.38.0
Host: mirrors.kodi.tv
Accept: /

< HTTP/1.1 200 OK

  • Server nginx is not blacklisted
    < Server: nginx
    < Date: Fri, 19 Feb 2016 13:56:18 GMT
    < Content-Type: text/plain; charset=UTF-8
    < Content-Length: 44
    < Connection: close
    < X-Frame-Options: SAMEORIGIN
    <
  • Closing connection 0
    fd9407fb3c1d4d03d53b99e12163653d addons.xml

Thank you for the help :wink:

This is really odd, so I assume you exectued the curl command from the command line of the Pi2?
Also what I don’t understand why do you have http://addons.kodi.tv in your sources.xml?

yeah, I executed the curl command through ssh.
I just wanted to try to add the addons.kodi.tv to the sources, because it was a clean install and didn’t work anything which is using internet,but only from the ‘My OSMC’. So it isn’t working to get any data from movies, audio, cant get any addons etc… But I installed the transmission from the ‘My OSMC’s App store’ and the transmission works normally.

Ok, I suggest you remove the two external sources that you have added to sources.xml and then try again. If it still doesn’t work provide logs again.

I removed the added sources. Nothing happened.
So, again :
The problem has existed since the installation.
I have network connection, I can install apps from the my osmc menu. Like the transmission, and it is working as normally.
Here is the log :
http://paste.osmc.io/fekuforuno