Update to OSMC 2016.01-2 NOT 16.0 Build


I want to remain on 15.2 and not upgrade to the new Kodi 16.0 build (due to shared library).

How do I get the updates for 15.2 (OSMC 2016.01-2) and not do an upgrade to 16.0?

If I do an apt-get upgrade (not dist-upgrade) in ssh is it ok to upgrade all these packages on a running 2016.01-1

The following packages have been kept back:
rbp2-kernel-osmc rbp2-mediacenter-osmc
The following packages will be upgraded:
armv7-libshairplay-osmc base-files-osmc libc-bin libc6 libgcrypt20
libgraphite2-3 libgssapi-krb5-2 libk5crypto3 libkrb5-3 libkrb5support0
libtiff5 locales mediacenter-addon-osmc mediacenter-skin-osmc
multiarch-support perftune-osmc rbp-bootloader-osmc
17 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 33.3 MB of archives.
After this operation, 201 kB disk space will be freed.
Do you want to continue? [Y/n]

Thanks in advance,

You can hold back the ‘mediacenter-osmc’ package, but this is not advise and not supported. Sooner or later something will break.

Just stay on the build you are on for now if you are happy.

Ok thanks, I’ll stay on 2016.01-1 then. Cheers

You should not do apt-get upgrade instead of apt-get dist-upgrade - you will not get kernel updates either if you do this, and some packages that require new dependencies will also not update.

If you really must hold your Kodi version at the current version for compatibility with other devices then do:

sudo apt-mark hold rbp2-mediacenter-osmc
sudo apt-mark hold rbp2-libcec-osmc

This will hold both Kodi and libcec versions at their current versions. You can then dist-upgrade or upgrade via My OSMC to update other packages including receiving security related fixes. (For software other than Kodi obviously)

This is not supported or recommended but is probably OK in the short term on the Pi, however we would recommend that once you are able to update your other devices you unhold both packages to allow the system to fully upgrade.

Ok if its not recommended/supported I’ll stick with 2016.01-1 - so without the glibc security fixes…

sudo apt-get install libc-bin libc6

Will give you the security fixes.