Upgrade from RaspBMC to OSMC gives nothing but grief

One of my SD cards of my Rpi 1 failed so I had to switch over to a new one and after recovering an older image of RaspBMC I figured, why not switch to OSMC while I have to do this anyway, and so I did… but trouble quickly arose…

RaspBMC has been running stable for several years now, of course it glitched out every now and then but I’ve had uptimes of a couple of months without even rebooting it. I also had tried pretty much every overclock I could (pushing it to extremes of cpu 1100 with 550 core, SDram running around 500 and so on so on) without having much problems, I ended up running a fairly reasonable clock I was satisfied with but I know it was able to handle more and still be stable, I just didn’t see the need of it.
With OSMC i’m having a very very different experience. Whatever clockrate I set it pretty much runs on 100% CPU (ram is never an issue, tops around 50%, rarely) with slight drops to 98% but after a while it settles down and goes to normal CPU behavior ranging from 10-30% on a cpu 900 core 450 clockrate but the moment I start using it its back to 100%.
Not really a big issue still since the temperature doesn’t go past 55 degrees Celsius (Copper CPU heatsink and 2 small aluminum heatsinks, not using a cover so more then enough cooling), the major issue is that it keeps hanging. I can’t really call it freezing because I’m not locked out of the system, I have to SSH in and shutdown but it keeps happening no matter what skin I use, including the original OSMC skin.
I personally prefer using Rapier because of the extended info and the only other plugins I actually run (and always had running on prior system) is library auto update (set to 12 hours) and Trakt.
And of course any plugins that run with Rapier if I happen to have that skin enabled but keep in mind that this happens on the original OSMC skin as well.

My longest runtime right now has been roughly 5 hours without it “freezing” on me.The GUI seems to sort of still work because in some rare cases the screensaver kicks in but everything else is completely frozen and waiting doesn’t help (trust me I tried for several hours).

I also already turned the graphics down from 1080 to a 720 environment to reduce the load even more, didn’t help a bit.

If i go anywhere below Medium overclocking (instead of just custom) I get a frowning face after about 4 minutes of uptime so the standard profiles don’t really help with this either.

I’m running the latest OSMC, updated it as well to be sure.

My current config.txt is as followed.


This is fairly low for what I used to run but it seems to be the most stable I can get it with OSMC…

I could really use some help here because I’m running out of ideas.

TL:DR recap
Rpi 1, used to work great on RaspBMC for years with same plugins and skin, installed OSMC, works like crap, see settings, help fix this puppy, more info see above anyway :P…

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Rest of the info is above.

Log: link obsolete, new log coming.

These logs do not have debugging enabled. Also, if a crash occurred just prior to you uploading these logs, then this is the last thing that occured prior -
16:57:49 9385.600586 T:2431644656 NOTICE: script.tv.show.next.aired: ### TV Show - Next Aired starting GUI proc (6.0.15)

Try disabling the next.aired addon.

Will enable debug for a fresh log, sorry forgot.

As for next aired, i’ve been running that addon for yeaaars… Kind of strange it would suddenly become a problem… but lets see at the next crash.

And we have a “freeze” again. I must say that I stressed the system a bit but as soon as artwork fails to load up (plots load fine, so do latest aired so its not the plugin you mentioned) starting a video will cause it to fail. Actually its failing before that already because the artwork isn’t loading anymore.

Got a document length error so don’t really know what to do…


There are some reports about freezing lately. It seems the original Pi is more prone to this issue than the newer models. Some users have seen improvements in recent updates but some are still having problems.

We’re still not 100% on the cause. I would recommend:

  • start a fresh install
  • load up one add-on at a time until you get a freeze.

I know it’s painful, but could rule out any add-on / skin issues that might be causing this.

I can’t seem to get people off Raspbmc (which is still available here). However – I’d recommend not going back as fewer add-ons are supported now and support for Raspbmc itself has ended.


Thats basically why I switched over to OSMC, RaspBMC was sort of stable but lost all addon updates etc.

As for your checklist, the install is fresh from 2 days ago.
I only have 3 addons installed, the Auto Library Refresh, Trakt, and Rapier (I absolutely love the OSMC skin but I can’t see show plots, episode plots and you have to hover over the show to see how many episdes you actually have left instead of just seeing it right away, if that ever changed i’d move to the OSMC skin right away).

That being said, there isn’t much to disable!

If I switch to OSMC default (which doesn’t require any of the plugins at all) all that is left is the auto library updater and Trakt, both are crucial for me to use, the first because updates sometimes don’t come through and I don’t want to manually refresh everything to see if I missed something (now its done auto every 12 hours) and Trakt, so that if my Pi fails I don’t have to mark every episode as watched again, it just picks up everything I already watched from trakt and applies it to kodie.

So there really isn’t anything left to turn off at that point… I think…

You might have only installed 3 addons yourself, but rapier installed a bunch more for you,
Artist Slideshow
Artwork Downloader
Global Search
Skin Helper Service
Random and Last items
Skin Widgets
TV Show Next Aired
Rapier UI Sounds
Image Resource Selection script
White Studio Icons add-on

Maybe one or more of those is causing the problem?

I’m thinking that the rapier skin may just be a bit heavy on a 512mb Pi. Does the behavior only appear after you install rapier?

I have been running rapier for about 4 years now, so I doubt its too heavy for a 512mb Pi since it was stable pre-OSMC :stuck_out_tongue:

There is 0 ram issue, it uses roughly half of my RAM tops even when watching the debug, and honestly, on RaspBMC I’ve ran it while running transmission, and a few other programs as well, I then used a USB stick instead of just a card but that doesn’t mean it didn’t stress the system. It still ran semi-stable, I had to wait for things every now and then but it never froze on me.

But ever since OSMC it freezes with just Rapier, auto update and trakt.

Did it run better pre-install of Rapier… not really, it froze as well, it wasn’t this bad but it still did.

For some reason OSMC also makes previoously tested overclocks instable. I could run my Pi on an extremely high OC on RaspBMC while it makes my system buggy on a 1100/500 CPU/Core clock already and requires a much higher overvolt to even be stable. It makes no sense at all.

Back to the Rapier might be too heavy issue, it freezes when using 30% CPU as well, running in debug mode the CPU is just fluctuating between anything from 30-100% and everything actually keeps working (info text keeps scrolling etc.) but the navigation freezes all together. I have the exact same issue using the default skin so its not the skin itself.

Like i previously said, it makes absolutely no sense to me, I’ve been using and tweaking Pi’s for ages now and I’m just hitting a dead end… I know I’m due for an upgrade but I still want this one to function properly so it can be use as a secondary system if needed in the future.

We need to narrow down where the problem is.
Can you first disable any overclock and confirm if that makes a difference?
If you still have freezes then can you switch from rapier to confluence?
By “auto update” do you mean a library updated or something else? If it’s a library updater then disable that.
If still an issue then disable trackt.

We’re not saying you can’t use these features, but we do want to know if one of these changes makes things more stable. Then we’re in a better position too look for solutions.

No overclock turns into a frowning face splash screen after about 4 minutes and reboots kodi (thus making it worse, the only profile that starts making it more stable is the one posted a few posts above this one, Custom settings is the most stable way I could get it, none of the default profiles seem to stabilize)…

No difference between Confluence, Rapier or OSMC.

Disabled Library update, it gives a slight improvement during the startup (which was to be expected because it doesn’t scan for content) but does not fix it.

Disabled Trakt, no significant changes, like Library update it lowers the CPU usage when in use which was to be expected but not the overall CPU usage.

Keep in mind that the library updater and trakt both trigger on events and are just background processes that are mainly idle unless either library updater starts scanning for content (on startup and in periods of 12 hours) and Trakt only kicks in after library scans or when media is played and information is scrobbled.

Running the debug it shows Kodi using roughly 98% CPU on its own when stressed, once settled down it drops to 30~ and fluctuates between that and 60%. CPU temp does not pass 55 degrees Celcius.

I know that it worked well on Raspbmc, but that was less strenuous on power supplies than OSMC is, and it’s possible your power supply’s capacity has degraded over the years.

Can you check that the power supply is good? Some of the symptoms sound like a power supply issue – particularly if high CPU is causing issues.

Is this Library Watchdog? I think that add-on can cause problems sometimes.

2 brand new power supplies give the same issue, all hardwired supplies, no usb cabled PS and all are confirmed to work on another Pi with a high overclock and my old Pi setup ofc.

Its not library watchdog its called (and of course it freezes again going out of a tvshow menu back to the main menu so rebooting) XBMC Library Auto Update, the logo is some sort of white and blue clock.
I’m more then happy to switch library updaters though I don’t really care if thats an issue.

Also keep in mind that the OS itself doesn’t freeze, just the frontend, I can’t navigate anymore and it hangs but animations (like rapiers scrolling show plot) generally still work most of the time even when it hangs, navigation is just impossible and parts of the UI hang (e.g. scrolling text works but the “busy” menu hangs or on the main screen the TV SHOWS menu button is greyed out and half way popping up but just hangs making navigation impossible while on the same page “shows airing today” still rotate)…
This makes it doubt that my PS is even remotely the issue.

Just a thought, but I have seen some issues reported elsewhere with crashes from corrupt, or incompatible, pictures.

Those have been when using OSMC to watch a slide-show, but if there are parts which perhaps don’t handle image errors as gracefully as perhaps they might need to, could it be artwork which is causing the issue?
That should be quite simple to check - when the system has “crashed” (GUI lock-up, can still “ssh” in), re-start and browse back to the same item which caused the crash previously. Hopefully that should display the same artwork, and if that’s the problem then cause the same crash.

Probably not, but it might be worth a try …

Good idea but I already tried that one, it was one of the first things I eliminated :stuck_out_tongue: its not the artwork itself, everything is loaded, it took me a few crashes to go through everything but I noticed nothing that was unable to load :slight_smile:

1 Like


Sorry, must have missed that …

Oh well, would perhaps have been nice had that have been the problem … I’m sure Sam and the rest of his team will get to the bottom of it all for you :slight_smile:

1 Like

I’m sure, I’ve never had any complaints about troubleshooting :smiley: not that I’ve had an extreme amount of issues in the past but the ones I did have all got resolved at some point :).

Ok so i’m able to add 2 states in which it can “freeze”. One is when I move through a couple of shows, the artwork will either stay the same (e.g. While going from Arrow to The Flash I see Arrow artwork with Flash episodes and information OR I the Arrow logo stays and the thumbnails will be grayed out) and an “idle freeze”, I just Pi on all night while inside a show directory, CEC picks up fine (I’m able to get out of screensaver mode), all the artwork looks good, info is scrolling (animated) but I can’t move up or down, select anything etc. with a keyboard or through CEC.
In both cases the actual Time keeps running and stays correct even after the freeze.