Upgrade XBMC to OSMC, IR remote problems

Hi,

I upgraded my old XBMC system (RaspBMC, Kodi 14) on RPi1 to brandnew OSMC. Most is working fine, except for the IR remote. I have a TSOP receiver connected to the RPi and configured to MCE. This worked fine with the old system. However after the upgrade and adapting the config (enable IR remote, set to MCE) the remote is still not functional (no response at all).
Did the GPIO pins assignment change between RaspBMC and OSMC?

GPIO pins can be configured via MyOSMC -> PiCOnfig assuming you also configured your remote there

AFAIK I used the default setting on RaspBMC so I’d expect the default setting to work on OSMC too. So I should have been more precise: Did the default pin assignment change?

OSMC is not Raspbmc. Assuming that nothing changes is an error. We’ve made the assignment of gpio pins simple via GUI in MyOSMC.

dmesg says:
[ 7.409017] lirc_dev: IR Remote Control driver registered, major 244
[ 7.518903] lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
[ 8.509990] lirc_rpi: auto-detected active low receiver on GPIO pin 18
[ 8.513480] lirc_rpi lirc_rpi: lirc_dev: driver lirc_rpi registered at minor = 0
[ 8.513508] lirc_rpi: driver registered!

GPIO pin 18 corresponds to the (default (and actual)) setting of OSMC so apparently this is ok.
Still puzzling…

Stop Kodi and check if button presses work with irrecord

Got it working. The final (and confusing) factor was that MyOSMC > Remotes always shows the alphabetically first remote in /etc/lirc/ so I thought the change to rcs-mce-lircd.conf was not effective.
Thanks for the support and patience.