UPnP doesn't show ALL Folder content in Kodi New OSMC Install on Rasberry Pi3 B+

I use KODi exclusively to send my extensive Multi-Disk Video content from my PC to my TV by WiFi using “Universal Media Server” on my PC.
For many years, I used an Android box running Kodi Helix v14.2… But it is getting old and beginning to crash… Plus I’ve added a new TV.

So I bought a new Box running a version of Krypton for the New TV, but I found that though I have UpnP/DNLA set up on the Box and connected to “Universal Media Server”, And all the drives and Top level Folders are Visible, When I click on a Folder, I often get No content showing in some Folders, Not even a .jpg cover Just a Blank screen in the KODI GUI…

However Other folders I click on show Playable Content, Jpgs and Sub Folders and Content there as well. So I Tried another Box running Leia V18.Alpha… Same Result… All Drives and Top-Level Folders showing, But only about 50% are showing Content.

So I thought that the Problem can’t be KODI, so there must be an issue with these new Android Boxes, and decided to try a Raspberry Pi 3 B+ running the latest version of OSMC and…
Same THING !!!

This doesn’t make sense… WHY is some Content shown, and not other… I checked the Files, and it doesn’t matter if it is an MKV or an mp4… In some Folders I see them… In others I just open up a Blank screen…

This is getting Very Frustrating, and if my Old Box running Helix dies, I have no way to send content to my older DUMB-Samsung TV. I’m not a Tech or Kodi expert… ANY Advice please??

Or is there any place I can get an OLD Installer version of OSMC or Pi-OS with a Version of Kodi Helix, or maybe Isengard??

Mucho Thanks,

Have you properly setup the sources and scanned them into Kodi? I don’t think that UPNP will work properly until you do that.

1 Like

I have used KODI for many years, and I have definitely set up UPnP…
I have no interest in scanning to the KODI library… I’ve never done it before, and I do believe I’ve read that it is impossible over UPnP anyway… I just want Direct access to the Folders and Content on my PC… and KODI has always allowed this in the Older Builds (Helix).

However… as I also stated above… I do get access with the Newer versions of KODI… Unfortunately, NOT all Content is Visible, and I can discover no reason Why some Folders will allow Content access… and Others will not.

I’ve given up on KODI, unless I can find a Version of OSMC with an embedded Helix or Isengard installer!!

Ok, since it’s a Kodi bug, I suggest you take this to the Kodi forums then.

We believe this is a Kodi issue or a specific Kodi function and as such you should look at addressing the issue there. If you do believe that this is an OSMC specific issue, please let us know.

Again… All I am asking for here, is access to downloading an OLDER version of OSMC with earlier (Helix or Issengard) build of KODI in the Installer.

Kodi has No interest in solving UPnP Issues… Not from the Age of posts going back to Krypton, complaining about the same or similar Issues!!

Unfortunately, if I can’t find an older usable installer version, Then OSMC Kodi edition is as useless to me as is Kodi, and I will be forced to try with Plex… NOT my favorite UPnP server!!

Thank you,

Knock yourself out friend.


@ActionA beat me to it. But I don’t think any of the available Pi2/3 images go back that far.

Well, there’s always the Wayback Machine…


I’m not sure what the state of OSMC was back in June 2015, but it’s showing some RPi images for that date.