UPnP playback issues

Hi all. Thanks for all the stellar work thus far.

It’s been a while since I have had time to test but I finally had a small window this evening and have come across a couple of issues with regard to UPnP playback.

I have a RasPi B (512 MB), running the latest RaspBMC, acting as the UPnP server and a RasPi B (256 MB), running OSMC Alpha 4 (with latest updates) connecting as a client. On the OSMC client, when I go through the Video menu via Files and select the UPnP Pi, everything continues as expected until I get to the point where the final selection brings up the list of available TV shows… at this point it takes over 5 minutes to create the list (another 512MB RasPi B client running RaspBMC presents the list in about 15 seconds). Once the list finally appears, selecting a program folder doesn’t open further to the Season level. No error messages are displayed and nothing happens beyond that.

The only way I’ve found to actually play a program is to, again through the Video->Files menu, select the UPnP server and then select Files (rather than TV Shows) under that, then select the content folder (in this case, one of the UPnP server’s connected Samba shares) and then I can select the Show folder and the subsequent Season and finally select a video file which will play without incident.

I attempted to log all this behaviour and paste it but I’ve been getting the following:

http://paste.osmc.io/Document exceeds maximum length.



Known issue. I need to increase the max upload size.

Thanks for that, Sam.

Any thoughts on the UPnP issues?


UPNP is buggy and its implementation in Kodi is not great. I would recommend you share the files another way. Raspbmc has a built in Samba server and OSMC will have one shortly


Interesting. I just set up my Pi2 as the server and the PiB as the client.

This is the first time I have tried sharing the library via UPnP but on the PiB the files load very quickly.

While I know UPnP in XBMC/Kodi isn’t perfect, it has always worked reliably enough for my purposes in RaspBMC and I would even say it has been very solid. I only started having issues with it in OSMC since Alpha 4, previous Alphas did not exhibit the same problems.