UPnP Service taxing Vero 4K+ CPU

Hi, everyone

I started noticing my Vero 4K+ dropping a few frames randomly during playback, and noticed pulling up CPU utilization showed one core maxed out at 100%.

Going into debug mode and looking at the log, it shows allot of UPnP activity; turning the service off in the settings brings the CPU utilization down to “normal” levels.

Here’s a debug log with UPnP turned on:


Is this somehow an issue with my particular setup (i.e., another component on the network making queries)?

This issue was present in the latest stable release, and is also present on the new test release, but there’s a catch. On the stable release, after a reboot the Vero behaved as expected, and the “UPnP storm” started sometime after several hours/days of use; on the test release, the storm seems to be there at every boot, but settles down after some time.


It could be a problematic client that is sending a lot of requests.

Firstly: do you use the Vero as a DLNA server? If not - the simplest solution will be to disable this functionality under Services in the Settings menu


Hi, @sam_nazarko; and thanks for the reply!

Yeah, disabling the UPnP media sharing is probably the quickest way to stop this.

Still, I’d like to better understand the issue. I can’t make much sense of the debug info, but was hoping someone with more experience would be able to get some sort of insight.


I’ve seen a lot of odd behaviour with DLNA causing high CPU in the past.

Unfortunately the DLNA integration in Kodi is not feature complete, so that could also contribute to the issues.

Do you have any smart TVs? Do you find that disabling their network connectivity resolves the situation?

I still think the simplest solution would be to disable the DLNA server but we could investigate it further if you do plan to use DLNA in the future



I do have a LG smart TV (and other networked UPnP media devices), but none whose network I can cut off without compromising usability.

I’ll probably run a few more tests, and if the strange behavior remains, just keep UPnP/DLNS library sharing off in the Vero.

Thanks again for the feedback.