USB 3 HDD not working anymore

Hi,

I have been using an externally powered USB 3 Hard Drive since my first Raspberry (1 Model B+), powered by an iPad 2 charger (5.0v - 2.1A) without issues. When I got the Raspberry 2 I also added a DVB Tuner and a USB Printer, all of them worked flawlessly.

I got the Raspberry 3 a while ago, and everything kept working without problems.

A couple of weeks ago, I found the Raspberry switched off, I detached the power supply and reattached it, and everything booted up, apart from the USB 3 drive, which only powers up when it’s recognised by the host. I then tried it on my PC, and it worked fine.

I tried installing OSMC from scratch on a new sd card and booting from that, the USB 3 drive didn’t start.
I thought that maybe the logic board of the USB 3 case was the problem, so I tried with another externally powered USB 3 docking station, the docking station’s led shows that the disk is recognised, but I can’t see it on OSMC.

I also tried changing the usb cable attached to the iPad 2 charger to no avail.

I tried using a USB 2 adapter and the disk works without problems.

Dmesg shows “usb 1-1-port2: over-current change” with both the USB 2 and 3 adapter, this should prove that the charger is not the problem? Or is it possible that it kind of lost efficiency in the meanwhile?

Unfortunately I don’t have a voltmeter or any kind of stuff to measure the charger’s output volts.

Can anyone help me find what’s wrong?

Thanks in advance

Entirely possible. Hardware degrades over time.
Also, Apple iDevice chargers have never proven to perform well at maintaining voltage when demand for amperage increases.

iPad chargers are not suitable for Pi. They drop as low as 4.5V which is not enough. I’m surprised the Pi 3 actually works at all with one.

This is a suitable PSU (and manufactured by us):

https://osmc.tv/store/product/raspberry-pi-power-supply/

Well, since we’re talking about 2 years 24/7 of charging, I kind of expected this to happen anytime soon…

Sam, do you know if the shipping company allows shipping to a PO Box or directly to the Post Office? I’m not available at home during the day and I don’t have anyone that can receive packages on my behalf.

We can ship low value items (i.e. PSU) to a PO box.

No shipping for a few days (on holiday), but we are offering 10% on everything if you have the patience. It’s a good PSU, and should last you many years.

Thanks, I’ll buy it right away, I’ll manage with the usb 2 adaptor in the meanwhile.

Have a great day!

I have received the new power supply, which still isn’t able to power the usb 3 disks somehow (they have been working fine for a while and they work fine with a PC).

Dmesg still shows “usb 1-1-port2: over-current change”. Could this mean that one or more of the usb ports are defective?

Have you tried connecting it to a powered HUB to exclude the power from the Pi3 being your problem.

Have you tried to connect it to any of your Pi2 or Pi1 to check if it works there?

I don’t have the Pi1 nor the Pi2 anymore…

I’ll try attaching a powered usb hub to the Pi3 and see if it works that way.

Thanks!

I find this thread interesting.
I suggest that it is possible that the Pi was off after a power glitch in the public supply, and this has affected the electronics in the usb3 interface.
I have had several of these in the last couple of years - the drive is still accessble from a Windows PC, but not from a Pi.
As a result, I now have several drives which I have fitted with new usb interfacing, thus restoring them to use on a Pi as well as Windows PCs
Derek

I tried using the same drive on a different usb 3 docking station and it’s not recognised on the Pi 3, but it is on a PC.

Hopefully it’ll work with a powered usb 3 hub…

Status update. I’ve been using the new power supply for a month now, it works splendidly.

Unfortunately any usb 3 device still doesn’t work, even if i attach a usb 3 powered hub in between.

Usb 2 works perfectly. Seems the usb 3 interface really was damaged by the power glitch somehow. I’m going to buy another raspberry 3 then.

Thanks for the support all of you!

Not 100% sure what you are talking about but there is no USB3 interface on the Pi3

I don’t know what else could have happened then. I still have to get a new Rpi3, hopefully USB 3 will work once again.

Hi there and sorry for necroposting, but I wanted to give all of you an update about this, even if it’s bad news.

Today wifi, bt and ethernet all stopped working, i cannot see them in osmc network config app, so whatever happened at the beginning has now put an end to the raspberry.

Thankfully I’ve already bought a Vero 4k that will hopefully come soon.

Cheers and thanks for the support.