USB install stuck on formatting device

greetings and salutations,

i had been running osmc successfully on an usb stick with the rpi2 since the june release and my wife and kids love it. all the osmc updates went quite smoothly until the sept release where osmc stopped booting completely. i then made the mistake of reformatting the micro sd as a fresh install instead of trying to export a log to see the error. now i’m stuck on formatting device whenever i try to reinstall osmc on a usb stick.

i’m aware the rpi2 can demand more power hence i am using a 5V 2.5A charger hence i have never come across the colorful box in the upper right screen. i have tried reinstalling osmc about ten times all getting stuck at formatting device before i tried openelec on usb stick and i am able to run openelec on usb stick. our rpi2 is currently running openelec on a usb stick. since we prefer osmc, i’m trying to figure out why i always get stuck at formatting device even after numerous attempts. both red and green led lights stayed lit.

i’m using a 2gb micro sd with a 16gb monster digital usb3.0 with the rpi2 powered by a 5V 2.5a charger. i don’t have anything else plugged into the rpi2 other than the ethernet and the hdmi cable. i’m using the kore app as the kodi remote. sorry for the long story and thank you for any insight and suggestion. thank you osmc and developers.


just some ideas:

  • Have you checked sd card and usb stick at your PC? Using Windows I can recommend the tiny program h2testw H2testw | heise Download. Unfortunately the sides are in German, the app can be switched to English. The sd-card and USB stick have to be reformatted on the Windows System of cause.
  • After you’ve tested your sd-card and USB stick, retry the installation. If it is stuck again, wait some minutes, power off the pi and and place the sd-card again into your PC. You should look for a file “install.log” which should be located in the visible partition to Windows since it is a vfat partition. Paste it here (should be quite short) as preformatted text or upload the file to and provide the link here.

Perhaps with this Information you get some more interest from the more active people, here.

Greatings from Germany,

hallo @JimKnopf, greetings from northern california. i kept getting stuck at formatting device hence can’t get pass it to reach install so there is no install.log on the micro sd card upon inspection using windows. i would have include a log if there is one. i’m using this tool to ensure the mirco sd card is formatted correctly SD Memory Card Formatter for Windows Download | SD Association but the osmc-installer.exe tool prepares the sd card for usb install so i’m puzzled as to why i kept getting stuck at formatting device. i have even formatted the usb drive to ext4 primary and still get stuck at formatting device. danke.

If you’re using a USB install then the formatting that is failing is formatting the USB stick, not the SD card. SIlly question, but do you have the USB stick inserted in the Pi during the install process ?

Also to help rule out any problems with the Pi and the SD card, does a normal SD card only install work OK ?

hi @DBMandrake, not a silly question and thanks for asking to be sure. yes i have the usb drive inserted during every install process. i have formatted the usb drive and retried the install in either fat32 and ext4 primary and still no luck; still getting stuck at formatting device with both red and green led stayed lit. i am using a 5v 2.5a charger hence i do not see the colorful rainbow box in the upper right corner. i’m stumped hence asking to see the issue is only me. currently i’m using the same micro sd and usb drive running openelec on an usb stick but i just prefer osmc.

i used another micro sd card, 16gb, so the entire osmc can fit in one sd card. normal sd card install worked without any issue. the getting stuck at formatting issue only occurs with the usb install using the 2gb micro sd card and 16gb usb3.0 stick. thanks again.

You don’t need to format the USB drive. OSMC will do it for you

There should be a log file on your SD card after running the installer. Please upload that


Make sure you are using the OSMC windows installer to image the SDcard, not the USB. Then boot pi with SD and USB connected.

hi @ActionA, yes i am using the osmc-installer.exe installer in windows to image the micro sd card. the rpi2 boots up with both the micro sd and usb stick inserted. the osmc imaged micro sd card formats the usb stick as part of the install process.

hi @sam_nazarko, i made another attempt with the osmc usb install and i am stuck again at formatting device. i let it sat for at least 30 minutes before powering off. i removed the micro sd card and checked the files in windows. these are the only eight (8) files in the sd card and none resembling a log file. my thought is i can’t get pass formatting device hence osmc install hasn’t started yet.

How big is the USB?

Do you have another stick you can try?

hi @sam_nazarko, 16gb usb3.0. unfortunately i don’t have an extra one at hand to try. i can install openelec on the usb stick and it runs openelec without any issue but i just prefer osmc. i already did scans on the usb stick to see if i run into any error and all scans show no error. not sure why i’m stuck now but my very first attempt with osmc usb install was june and it went without any glitch. all updates have been no issue until sept release.


Without a log I am not sure what can be causing this. I’ll try and test a USB install later this week and see if there are any new regressions in the installation process.


Hi amboy,

the SD Formatter you’re using can format the SD Card and erase it … but it will not verify the correctness of each block.
Give h2testw a chance and use it with your SD Card and the USB stick, so you know that both are in a healthy state.

hallo @JimKnopf, thanks for the tip. actually i have used the minitool partition wizard Best Free Partition Manager for Windows | MiniTool Partition Wizard Free and scanned each block on both the usb stick and micro sd and all came back without error. i have successfully reinstall openelec on the usb stick after a couple of failed attempts to reinstall osmc with the hope i can upload an install log for sam but no luck. he says he’s going to test a usb install later in the week for possible regression but for now it appears my only alternative for an usb install is with openelec. danke.

hi @sam_nazarko, i have been thinking since the only issue i’m facing is being stuck at formatting device, i wonder if an option exists for one to modify the install files (or modify cmdline) in the micro sd card so that the usb install would bypass formatting device and go straight into installing files. my thought is one can simply format the target usb stick to a file system format the micro sd card is expecting. thanks again for the excellent work. best regards.

PS: i wish the usb install script doesn’t default with formatting usb device but checks the usb device whether it has a single partition with a desired file format. installing files should proceed if the usb device is already correctly formatted. if the usb device needs formatting, then it’s appropriate to format the usb before installing files. just my 2 cents.

May I ask why you insist on using the USB install?

hi @ActionA, that’s a fair question. i have a 2gb micro sd card and a 16gb usb stick. my other micro sd capacity is even smaller at 1gb haha. these are from old cell phones but since i have a 16 usb stick, my thought is to put my old things to good use. i am currently running the rpi2 on openelec with the 2gb micro sd and the 16gb usb stick. i had osmc installed on the exact setup since june but sept release update didn’t go well and i made the mistake of making a fresh install instead of downloading the log to check the error.

Before wasting more time I think you should try it with another stick just to be sure it is not a general problem with your Pi.

BTW. is this Monster Digital USB 3.0 16GB flashdrive the one which has the additional OTG micro USB connector? What jack of the stick is connected with the Pi? Any cables between the Pi and stick? Have you tried all 4 USB ports?

I personally would not invest more time without having tested another cheap pendrive, before.

hallo @JimKnopf, yes you have correctly identified the usb stick. the regular usb jack (not the otg micro) is connected to the pi. there is no cable between the pi and the stick since the stick in inserted directly in one of the ports. yes i have tried all four (4) ports thinking perhaps the pi has one faulty port. unfortunately all my other cheap usb drives are 2gb or less haha. i do not think the issue resides with the pi since i’m able to use other usb input devices like a keyboard and a mouse. i will try to find another stick. like i have mentioned in other replies, the pi is currently running openelec on this same usb stick. i am trying to install osmc on it since i kinda like osmc. danke

hmm… it’s been little over a week now we’re running openelec in the aforementioned 16gb usb stick without issue. i cannot honestly say openelec has started to grow on me but i’m hoping to find answers on how i can get pass the formatting device when installing osmc. i am not convinced the usb stick is the issue since it’s less than 3 months old and it does whatever i needed it to do and i tested it to make sure it wasn’t the issue. i can format it and use it to transfer files. it’s been scanned a few times to ensure there is no bad sector. both windows and ubuntu recognize it when inserted into the usb port hence i don’t understand why i’m getting stuck at formatting device when installing osmc. there is no log in the sd card for me to share since install hasn’t started yet. and yet i can repeatedly install openelec with 100% success every time. anyway, just sharing my thoughts and i don’t mean to offend or to devalue all the hard work and great product the osmc developer team has delivered. is there anybody out there having similar difficulty in installing osmc on a usb stick? best regards to all.