USB keyboards are not recognized

My Vero seems to ignore USB keyboards. I’ve tested using either of the two USB ports and have also tried using a powered USB hub without success.

I’ve tried two different keyboards:

  • Apple model # A1243
  • Microsoft Natural Ergonomic Keyboard 4000 v1.0

No keystrokes on either keyboard are recognized. Neither keyboard’s caps lock, etc. LEDs will light up, but the “Fn” LED on the Microsoft keyboard does light up. So it appears the keyboards are receiving power, but that seems to be all I can verify.

Other USB devices — specifically a wired mouse and USB flash memory “stick” — work perfectly.

Any advice?

Very strange, I plug a Logitech K120 keyboard into my Vero all the time without any issues, and if other devices work it doesn’t sound like a faulty port.

Please post the output of dmesg with the keyboard connected so we can see what the keyboard is being detected as. You can do this from the log uploader in My OSMC, or by the following ssh command:

dmesg | paste-log

I did so and both keyboards appear to be recognized by the kernel. However neither seem recognized by OSMC. (Either that or the key mapping is incorrect).

When was the last time you ran updates from My OSMC ?

Your log shows you are running the 3.14.37-3-osmc kernel compiled on April the 12 - this is way out of date, and was released around the time that RC2 was so from that I can only assume you are still running RC2, which is now two releases out of date.

A lot has changed in the Vero kernel since then, not to mention elsewhere in the system so please bring your system up to date first, and if you are still having the same problem let us know.

Thanks for the reminder. I guess I haven’t been paying much attention to the OSMC/Vero community since shortly after I received my Vero. Updates and changes — although enabled on the Vero — haven’t been occurring, probably due to an oversight on my part. The Vero is updating as we speak. I’ll see what changes this makes.

Thanks again!

Not your fault - while update checks default to a daily check (but only actually installing with your confirmation) earlier versions of the Updater in My OSMC (including the one in RC2) had a bug that caused it to not actually perform the automatic check that was configured.

Once you have updated this time automatic update checks will work in future however.

The Vero still doesn’t respond to any keypresses.

After the update, the following is the log-dump…

Can you describe how you have your USB devices connected ?

It looks like the Apple Keyboard has a built in USB hub and that you have your Optical mouse plugged into that hub in the keyboard ? The log shows the Optical mouse disconnecting / losing it’s connection:

usb 1-1.3: USB disconnect, device number 4

Does the keyboard work if it’s the only device plugged in ? I would not recommend plugging another device into the keyboard because effectively that Keyboard has an unpowered USB hub in it so you are trying to power multiple devices from one port on the Vero - this may not work.

Go back to basics and test it with only one keyboard and nothing else plugged in, if it works then it’s an issue of power two devices through one port.

After the update within the last few days the keyboards seem to be working!

Quite bizarre but I’m glad it’s working for you now. :slight_smile: