USB SSD not automounting in /media

So, I’m having this weird issue with a SSD not auto-mounting, that I need some help with.

I have an SSD using exFAT, that had previously been connected to my Raspberry Pi 3 through an USB-to-SATA converter, where everything is working fine. Since the SSD was to be permanently attached, i purchased an AUKEY USB enclosure, to install it in (Amazon link!).

When I connect the new enclosure with SSD, the disk does not automount and does not appear under /media. The device is showing up in dmesg, and I am able to mount it manually, and access the files on the disk. If i run fdisk -l, the SSD is also present:

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1        2048 250066943 250064896 119.2G  7 HPFS/NTFS/exFAT

I have tried rebooting several times, plugging the SSD in after startup, leaving it in while in startup, changing USB-port etc., but nothing seems to make any difference. I have even made a completely fresh install of OSMC on a spare SD-card, to rule out any problems with my usual setup (LIRC, SMB-shares, etc.).

I have another USB device attached as well (Sandisk Cruzer Fit 16 GB that stores images), and this device is being disconnected and reconnected, every time i connect the enclosure with the SSD. This is not happening, if I’m using the old USB-SATA connector. Note that the automounting-issue I have with the USB enclosure is happening, even when it is the only device connected.

So, I have a strong hunch that the enclosure is the culprit here, but I dont know why or how to fix it. Since I am able to mount the disk manually (when installed in the enclosure), I dont suspect that the unit is faulty. The enclosure is also working without problems on my Windows PC. I don’t suspect a power issue either, since the Raspberry Pi does not reboot or freeze, and because the disk is showing up fine in /dev and can be mounted manually.

Debug logs are attached here.

The logs show a bootup where the enclosure is not connected to the Rpi, but is being connected after startup. I have tried following the “How to submit a useful support request”-topic, but please let me know if I have missed anything :slight_smile:

Thanks in advance; any help is greatly appreciated :slight_smile:


Most likely power. Try using a powered hub. Low power will not often result in reboot or freeze.

As @actiona wrote very likely a power issue. Either try a better/new power supply or for a setup as yours a good powered USB Hub for the external devices might be best

Thank you both, for your replies :slight_smile:

I’m currently using the Official Raspberry Pi PSU at 2.5A, which I hoped was sufficient to power at least one HDD/SSD. If a better PSU exists, you are welcome to recommend one :slight_smile:

Since this is behaviour is only happening when the SSD is in the enclosure, it must be that which has an higher power draw when connecting. I have had other 2.5" HDD’s attached working fine - as did the same SSD when using another adapter.

Will see if I can source a powered hub, to test it out :slight_smile:

I get that a power issue sounds plausible, especially since the enclosure disconnects the other USB drive when plugged in. However, if it is indeed a power issue, how can it be possible, to mount the disk manually afterwards and access the contents? Shouldn’t it refuse to work at all? :slight_smile:

It’s a valid point but considering that power just be marginal different factors can play a role.
The strange thing is your logfile neither shows any USB disconnects nor does it show any UDEV actions.

I have finally found the time to test it out with a powered hub. By Sam’s recommendation, I purchased the official OSMC USB3 powered hub, and have tried it today. Loving the hub btw; big fan of things with switches.

Aaanyway, the result is unfortunatly the same - the drive is not being mounted automatically, but is still showing up in fdisk -l. The other USB device I have (which were being reconnected, when I plugged in the new case), is not being disconnected now, so that was probably power-related :slight_smile:

So, since the (potential) power problem has been resolved now, are there any other things I can try to get this thing working?

after plugging in the drive provide grab-logs -K -J

Yeah of course, sorry. Did a reboot and then plugged in the drive. It is still showing up in /dev and using fdisk -l.

Logs are here.

Can you show:
partx -s /dev/sdb | paste-log
ls -lah /dev/sd* | paste-log
blkid | paste-log

Sure thing; thank you for taking the time to look at it :slight_smile:

partx -s /dev/sdb | paste-log at

ls -lah /dev/sd* | paste-log at

blkid | paste-log at

The extra device called FANART is the aforementioned SanDisk USB-stick. The SSD in the enclosure is called “Music” (as shown in the last log).

looks all good, no idea why udisk doesn’t jump in.
Maybe @DBMandrake has an idea

Is it gpt or msdos formatted?
Disk seems to be mounted: Aug 23 16:02:49 osmc udisks-glue[395]: Device file /dev/sda1 mounted at /media/FANART

@sam_nazarko thats sda1 that is mounted. But sdb1 is not automounted!

As far as I can tell, it is formatted using MBR. The filesystem is exFAT as previously mentioned :slight_smile:

Can you do:

sudo apt-get install parted
sudo parted -s /dev/sdb print

Sure thing:

osmc@osmc:~$ sudo parted -s /dev/sdb print
Model: ATA SAMSUNG MZ7TE128 (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  128GB  128GB  primary

That’s strange.

parted doesn’t show a filesystem.
udisks will only try and mount if it can detect the filesystem.

Does mount -t exfat /dev/sdb1 /mnt work?

Are you able to move data off the drive temporarily?

I’d format with something like:

dd if=/dev/zero bs=448 of=/dev/sdb
parted -s /dev/sdb mklabel msdos
parted -s /dev/sdb mkpart primary exfat 4096s 100%
mkfs.exfat /dev/sdb1

Maybe need to install exfat-utils for mkfs.exfat.

Probably better to use an official Samsung utility.

I just tried using the SATA/USB converter mentioned in the first post, and parted still shows no filesystem. However, the drive does mount automatically :confused: It is only when I introduce this specific enclosure, that the problem occurs.

I have to put a sudo in front of it, but otherwise yes :slight_smile: That was the way I did it manually before creating this thread.

Have tried to format the drive now in several different ways. Tried through Windows, on macOS and the way Sam suggested on the Pi itself. Nothing made any difference, and the drive did still not mount automatically, but manual mount still worked on all attempts.

I sourced another enclosure, to which I moved the SSD. Lo and behold; automount works. I have now tried four different drives (SSDs and HDDs) in two different enclosures and one adapter. The automount problem only occurs, when I use the AUKEY enclosure (linked in the first post), no matter which disk I install in it, and how that disk is formatted.

So as far as I’m convinced, the fault must be related to this specific enclosure in some way. I dont know what is so special about this enclosure, that it prevents the system from automounting any disk installed in it.

I think the path of least resistance is simply to find another case, instead of getting this specific one to work :slight_smile:

Thank you all for taking your time to help and look into the issue! Most appriciated :slight_smile:

1 Like