Using remote app

I have tried several of the iOS apps and also android and none can find my vero even if I manually enter the details. IP address, no PW or name.
Sometimes I wish I had gone for a commercial option that could be set up straightforwardly instead of having to do a dance every time I want to do anything.

Exesperated? Oh yes.

Have you confirmed that Kodi is configured correctly?

I am pretty sure it’s all ok, I have followed the instructions carefully. The IP address is and I have been told elsewhere that the problem is the iPad is completely different network The rest of the network is all similar. I understand I need to get an IP address which will use the same network but can’t figure out how to change the Vero/Kodi address.

Thanks in advance


That’s exactly what the problem would be. You must have these devices on the same subnet in order to communicate with each other (without a whole different set of issues to over come that is).

Do you control your router/wifi/networking devices? I’m guessing your Vero is connected by ethernet and your wired and wifi networks are on different subnets.

Make sure your iPad is not connected to a guest wifi network. (or a neighbours for that matter! :slight_smile: )

Most wifi routers support a guest mode that provides a connection to the internet but does not allow the wireless devices to communicate with wired devices. If they’re on completely different IP ranges they’re not on the same network and Airplay will not work.

Hi Mandrake,
all the devices connected to my network have the ip address, that is PC (wired), Router, WD my cloud server, ipad and even mobile phone. The only one that is completely different is the Vero which is
My question is how can I change the vero IP address to enable it to be on the same network. As far as I am aware i am not using air play for this task, I am simply using one of the apps which allows control of KODI via a device on the network.

Hi ActionA,
I have the Vero connected via wifi and I do control all the devices. see the reply to Mandrake for details. Is there a way to force the Vero onto the same subnet?



Yes, you need to make sure you’re connected to the same network as the other wireless devices and that your wireless router is configured correctly.

The Vero is not plucking that IP address out of thin air - it’s being assigned that address by your DHCP server.

If there is no IP connectivity between these two networks then you won’t be able to use a remote app.

As I suggested, it’s most likely you’re connected to a guest network as they are put on a separate IP range and do not allow communication with your wired devices or devices on your normal wifi network.