"Usupported alphas cannot be upgraded..."

Hi everybody,
I have 2 problems with my OSMC/RPi2 system.

First when I start my Rpi booting on OSMC, I have the following message :“Error in ArtworkRotationThread ; [error -2] Name or service not known”
I have to say that I’m using osmc skin…

Then, when I try to upgrade my system using manual update, I’ve got a popup telling me :“Ussuported alphas cannot be upgraded, please install the latest version of OSMC”… Well, obviously, I cannot upgrade this way…

So I tried using SSH with apt-get update & upgrade. Is it OK this way ?

Thanks for your help.

OK 1 problem of the 2 is solved : Fresh new install using windows self extract file.

Just to be clearer :
1/ I archive “.kodi” folder using “tar czvf archive_name.tar.gz /home/osmc/.kodi” command line
2/ Through FTP, backup this archive to my windows PC.
3/ Install RC3 through windows self extract file.
4/ Transfer tar backup file to RPi2 through FTP & then, execute “tar xzvf archive_name.tar.gz” from root folder