Vero 2 corrupt after initial update

I just received my Vero 2 today and I was getting it set up and I did an update on the packages and at it was processing the packages and it seemed to completely lock up for awhile so I hard rebooted it. After the reboot it came back up and I tried to try it again. This time it said it was holding back on packages (yet I believe the package being held back were the one it locked up on previously). I decided to add my network shares inside of /etc/fstab and rebooted the machine. It just hanged and went black. After hard booting it again I’m receiving an error where it can’t find the root filesystem device /dev/vero-nand/root and it booted me into rescue console. I have very limited tools in this mode and can’t seem to even get to nano or vim to check the /etc/fstab to see if it was corrupted. I’m also not sure if the packages are what caused this issue. I’d like to just roll it back to factory and I was curious if this is possible or if it’s possible to reimage it. BTW, I had OSMC running nice on my rasberry pi 3 and I experienced some lag and weird issues with the Vero 2 setting it up with delays and hearing phantom menus clicking on the background. I was curious what can I do? Is there a way to roll this back to factory? Is there a way for me to easily reimage this? Can I just run this from a microsd card or can I have the microsd overlap this image?

Hi

It’s not possible to brick a Vero 2, so the easiest way to restore things is to go to osmc.tv/download. There you will be able to use our installer, or (as you seem to be a power user) download an image which you can dd to your SD card. Insert this card, and you can reinstall the latest software on your device’s internal storage.

This should never happen. It seems that you might have tried to update via the command line. If you are to do this, you need to ensure you run

sudo apt-get update
sudo apt-get dist-upgrade

Running

sudo apt-get upgrade

Will cause issues.

It’s plausible that modifying fstab has caused some problems too, but I would have expected you to get a bit further in the boot process if this was the cause.

Let me know if you have any issues and enioy your new device!

Sam

Appreciate the reply. I got a new sdcard and used dd to put the image on the sdcard, however I inserted the sdcard into Vero 2 and it’s still loading to the recovery console. I’m not sure if an installer was supposed to start or whether I need to dd this from the sd card onto a device, if so how is it labeled?

It should just start.

You could rename kernel.img to recovery.img, and apply a non-conductive pin in the port nearest the HDMI connector. You will hear a click (there is a switch inside). Boot up holding this in for 10-15 seconds and it will force a boot off the SD.

I tried it again and same issue. Went into /dev as well and noticed mmcblk0p and mmcblk0p1 listed as well. I’m pretty sure this is the sdcard. I took it out and these devices disappeared so it appears to be reading it correctly. There also appears to no /dev/vero-nand listed. I’m not sure if this is the device used for the vero but I’m not seeing any other devices that I think might be the vero hard drive. Plus, despite this device being listed as twice as powerful as my rasberry pi 3 I was having weird issues with it locking up as soon as I took it out of the box and not feeling very responsive. The error I’m receiving is stating “waiting for root filesystem device /dev/vero-nand/root” and “FATAL ERROR: Could not find root filesystem device /dev/vero-nand/root - If this is a UCB install please check the UCB drive is connected.”

Did you try my suggestions above?

/dev/vero-nand/root is generated automatically on boot after initialising the NAND.

Thank you for the help. Did as you suggested and I think it’s going to be OK. It’s installing currently.

Should be fine. Be careful editing /etc/fstab and updating via command line. The safest way to update your system is via My OSMC -> Updater.

You can always restore your system if necessary (as you have seen).

Report back and let me know how you get on.

After it did the install it said it finished successfully, however once I tried to reboot the screen went off and hung with no response. I unplugged it and when it came back the system went into to Android system recovery (3e) KOT49H.20151218 test-keys. I appear to be stuck in a loop where I keep getting sent back into the system.

How did you try and reboot? The system should reboot automatically. If you pulled the power, you may have corrupted things. There can be a delay of a couple of minutes as all the data is written out from the SD to the NAND.

I do think I updated that message to only display when the final writeback is done, but if I haven’t, let me know and I’ll update the installer.

Sam

Never mind I did it one more time and this time it went through (it appears) correctly. Thank you again for your help. I’ll make sure not to do another apt-get update. BTW, for adding network shares which way would you recommend?

fstab is fine. You can also mount inside of Kodi, but you may see some performance overhead when doing this, particularly for SMB based shares.

Sam

BTW, Vero 2 is running much better than when I received it now. Probably the newer update. It’s much more stable.

1 Like

Issue appears to persist. Whenever I reboot or shutdown the system it comes up to the Android error. I originally thought this was do to my update, but then I tried your software update software and the issue happened as well. This time I didn’t even enable my wifi and it’s still crashing to the Android screen with nothing more than the initial set up done. Any ideas?

Sorry to hear that. Not immediately obvious why that would be the case if a reinstall succeeds. Can you try the following steps and report if you get problems booting?

  • Power off the system at the wall for 60 seconds
  • Load up SD card
  • Boot with non-conductive pin and when you get the OSMC installer, remove it.
  • When OSMC installs, go through the tutorial fully, configuring your system.
  • Go to power icon -> Reboot.
  • Do you still have a problem booting?