Vero 2 not booting anymore

My vero 2 stopped booting all of the sudden. After blue light it turns to red after like 5 seconds. I tried reinstall via sd card and it went fine, but then same result. After 5 seconds blue turns to red and it wont boot. Can you please help me?

Install log:
Thu Jan 1 00:00:05 1970 Starting OSMC installer
Thu Jan 1 00:00:09 1970 Detecting device we are running on
Thu Jan 1 00:00:09 1970 Mounting boot filesystem
Thu Jan 1 00:00:09 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:09 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:09 1970 Filesystem defined by /mnt/boot/filesystem.tar.xz
Thu Jan 1 00:00:09 1970 No preseed file was found
Thu Jan 1 00:01:16 1970 Creating root partition
Thu Jan 1 00:01:17 1970 Calling fmtpart for partition /dev/vero-nand/root and fstype ext4
Thu Jan 1 00:01:28 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
444400 inodes, 1775616 blocks
88780 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1820327936
55 block groups
32768 blocks per group, 32768 fragments per group
8080 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632

Allocating group tables: 0/55 done
Writing inode tables: 0/55 done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: 0/55 done

Thu Jan 1 00:01:28 1970 From a root partition of /dev/vero-nand/root, I have deduced a base device of /dev/vero-nand/roo
Thu Jan 1 00:01:28 1970 Mounting root
Thu Jan 1 00:01:28 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:01:28 1970 Using device->root: /dev/vero-nand/root
Thu Jan 1 00:01:28 1970 Extracting files to root filesystem
Thu Jan 1 00:01:28 1970 Starting extract process …
Thu Jan 1 00:01:28 1970 Extracting from /mnt/boot/filesystem.tar.xz
Thu Jan 1 00:02:42 1970 Extraction of root filesystem completed
Thu Jan 1 00:02:42 1970 Configuring bootloader
Thu Jan 1 00:02:42 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:02:45 1970 Configuring boot cmdline
Thu Jan 1 00:02:45 1970 Configuring /etc/fstab
Thu Jan 1 00:02:45 1970 Successful installation. Dumping log and rebooting system

If the light is turning red then:

  • Something is shutting it down
  • There’s a problem with the power supply
  • The device is overheating

You could also try booting the device without an HDMI cable attached.
What peripherals are attached to the device?

Overheating should not be the reason. Same happens if i try after one day. Without hdmi same issue. I need to try another power supply. Does it need to be the exact same or the amperage can be different. O dont think i have 2A laying around.

Amperage can be different, but voltage must be 5V.

Nope. Still same issue. Can device just be dead or is there something else i can check?

Oh and no other peripherals are attached.

Are you seeing the installer come up on the display?
If so – then the device doesn’t seem like it is dead.

No, when i try reinstalling the bblue light stays on for a longer time and no output from hdmi. no signal message on TV and after a while light turns red and if i recycle power then im at the same starting point again.

I would recommend trying on another display to see if you get a picture.

Just did that also. Same thing…also tried raspberry pi3 on primary tv and install screen came up normally.

If you put a toothpick in the recovery port, does the recovery screen come up?

Tried that. The blue light stays on now, but screen still saying no signal.

What model of TV are you testing with?

When’s the last time you used the device without issue?


Its a philips android smart tv. Other hdmi devices have no problem at all. Last time using it without issues was the day before i writed here.

Unfortunately it’s hard to tell what could be wrong with the device without taking a look at it. Particularly if you are not getting any visual indicator.

You can send it back to us to have a look at it, but we cannot guarantee that we could resolve the issue for you after this time