Vero 4K and Oppo

Hi. I just want to make sure I’m setting things up correctly. I have the Vero 4K connected to an Oppo 203 via the HDMI in. When playing an HDR mkv I hit the info button on the oppo it says the source is 1080p 444 10bit and is outputting 2160p 444 12bit. My projector reports the same 2160p 444 12bit. Now is the Vero adjusting the refresh rate or is my source actually only 1080p. I want the source to be 2160p HDR to take advantage of the HDR off features of the Oppo. I’ve searched the forum and using the echo 444,10bit line of code you put in the command line to go from 8 bit to 10 bit. I’m just not sure if I need to change the display in Kodi from 1080p to 2160p

Do you have Adjust Refresh Rate enabled? What happens when you connect the Vero directly to the projector?

My Oppo 203 is scheduled to be delivered today. I will be connecting it the same way to a JVC RS-500.

Yes it’s enabled. I haven’t gone directly to the projector. I did have the Vero connected to the receiver which then feeds the projector. The projector reported 10bit when I did that.

Something isn’t right with my setup and I can’t figure it out. As I stated in the first post I have the Vero connected to an Oppo 203 via the HDMI in port. I have the HDMI in specs option on the Oppo set to UHD HDR to allow maximum resolution. I also have the Oppo video resolution set to auto. When I go to the Vero Kodi gui the projector switches to 4k (3840/2160p) 60. However the kodi gui is set to 1080p. If I try to switch the gui to 3840/2160p the projector basically loses the HDMI connection and I get a blue screen. It can’t display 2160p even though it’s already in that mode?? I want the Vero to pass the file untouched so the Oppo can do the processing. I’m using the Oppo because you can turn HDR off yielding a better quality picture then the default JVC HDR setting which forces the projector into gamma D. When I play an HDR mkv and I hit info on the Oppo it says the source is 1080p 444 10bit. How do I get the Vero to pass the file in 2160p?

Enabling Adjust Refresh Rate is all you need to do for this to occur.
However, OSMC will only switch to supported resolutions

Can you upload logs via My OSMC -> Logs with your display on? This will tell me what the Oppo is advertising as supported via the EDID. It’s possible to override the EDID if necessary.

Sam

Ok I’ll do this later tonight. Is there a line of code I can test to override the EDID as well?

We would just change the list of modes (disp_cap) to force the output.
It’s important to get that information first.

Ok no problem. Come to think of it I moved the Vero to a different room to test it with using the projector. I think I might be using just a high speed cable instead of a premium HDMI HDR capable one. Maybe that is the issue?

Trying another cable never hurts

I tested connecting my Vero 4k to the input of an Oppo 203 last night and did not experience this problem. The Oppo info screen indicated the source was 4k. I have a JVC RS500 PJ and Marantz 8802a.

What Oppo firmware version and video output settings are you using?

IMG_3480IMG_3476IMG_3475

Ok good. I think the hdmi cable might be the issue then. I’m using the latest official firmware. It looks like you are using the oppo beta one which gives the HDR to SDR modes now. Looks like i need to upgrade to that one. I had read there were some issue streaming files from a NAS though so I was holding off. Are you streaming from a NAS?

Yes, I have a Synology NAS and tested streaming 4k via NFS and did not have any issues.

Same setup for me except Denon x6200. Thanks for this. It looks like it’s probably the cable

It was the hdmi cable. Back in business. Thanks for the help!