Vero 4K - Blue Screen and Sad Face

Hi all
I wonder if someone could help please. Recently purchased a vero 4k and have tried it for the first time in earnest today.

I have powered it up and I get a blue screen with a sad face.

I have gone through the pairing again of the remote.

I have tried to reinstall via USB as I do not have an SD Card and cannot get that to work either.

Could someone please help??


Are you following these instructions explicitly?

Please show a screenshot of the USB stick after you have prepared it.

Do you see the OSMC installer come up when you insert the USB stick?

Yes and then it says please wait, then a white block appears at the top of the screen, then an arrow in a green square background and then the following message appears :-

Install failed : could not mount bootfs

That’s odd. There might be an issue with images using USB sticks. Double check you’re using the latest image. If no joy, you would need to use an SD card. That will fix your problems for sure.

When I get a chance I’ll see if USB installation has an issue.


Hi Sam
Just wanted to thank you for your help yesterday as I have now re-installed with an SD Card and all worked like clockwork!!

Thanks - I just need to know how to setup SPDIF sound etc now but am sure that will all be through Kodi …



If you are only using SPDIF, then set # of channels to 2.0 and enable AC3/DTS if your receiver supports it. I’m glad you are back up and running. It could have been an add-on issue or some corruption that caused the sad face.