Vero 4k boot loop

Hi, first post and unfortunately it’s an issue.

I’ve had the Vero 4k for over 6 months and it’s been great. I can home the other day and the TV was on, with the Vero stuck in a boot loop.

I have unattached my hard drives and tried restarting many times, I’ve also tried reinstalling osmc via sdcard and USB but nothing.

The Vero box itself just turns on (blue led) then off again (red led).

Any help would be much appreciated. Thanks

Do you have an alternative PSU you could try? You can even power it from one of the USB ports if you have a decent USB PSU (not a phone charger).

Ideally you should remove the PSU before attempting this.

Have you tried reinstalling OSMC? That would be the first thing that I would try

I’ve tried reinstalling but it just won’t even get that far. It’s just a constant loop - though twice it’s got to the Kodi home screen for a split second but then rebooted.

I’ve tried power by USB, unplugged everything, even the ethernet cable but just the same loop.

It will boot up and after a few seconds reboot.

Still doing the same loop, I’ve even tried on different TV’s :slightly_frowning_face:

Really don’t know what next to do apart from having a replacement sent and swapped over.

Connect ethernet. Attempt to SSH into the box and gather logs? Otherwise, if you are still within warranty period, raise a support ticket here My Account – OSMC

if you don’t see the installer then OSMC isn’t being reinstalled, so the issue won’t be resolved.

Could you confirm that you’re using a micro SD card to re-image OSMC and you’ve followed the steps here: Reinstalling OSMC - Vero 4K - OSMC.

Please take a screenshot of the SD card contents after imaging. It’s quite likely that the device just needs a reinstall.

Of course, if you would prefer, we can take care of this for you. Simply send an email to


I managed to reinstall via another SD card which installed fine, then it went back to doing the boot loop again and has been for the past 15 minutes while I write this reply :frowning:

Sam, has anyone else ever experienced this?

I can’t think of a report of this off the top of my head.
A short video of the boot loop might get us on the same page as to what is happening.

As we’re both in the UK, the turn around would be quite quick, so why don’t you pop an email to and we can check out the device for you and ensure you receive something that works properly.