Vero 4K box not playing anything


#1

Hi all,

I’m using a 4 bay Synology NAS drive (currently with 2 x 4tb hard drives) to store movie files on. I’ve just gone and tried to update my library this evening and it’s not adding new movie files.

It also isn’t playing any files, I get a message saying ‘file is no longer available’ although I have the files on my computer. The Vero was working fine on Sunday when I last used it.

Does anyone have any ideas on a fix for this please?

If a log needs to be created could someone inform me how to do that as I’ve never done that before and my computer/gadget knowledge is very basic!

Many thanks!


#2

Sounds like there’s a connection problem with the NAS. Don’t worry, we can work it out.

First thing I’d do is go to System Info -> Network and see if you’re connected to the network. Can you try downloading and watching a program using the YouTube add-on?

You can do this under Add-ons -> Vieo Addons.

To send us logs, go to My OSMC -> Logs and upload all logs and send us the URL. You’ll need to be connected to the Internet for this to work.

Sam


#3

Hi Sam,

I’ve tried playing some content on youtube and it all plays fine but still nothing with my movie files.

Here is the log URL which I think I’ve done correctly:

URL:https://paste.osmc.tv/ohujesiwac

Thank you.


#4
21:47:02.021 T:3554468608   ERROR: GetDirectory - Error getting nfs://192.168.0.18/volume1/video/Movies/Hotel Artemis/

The files on the NAS are not accessible on the Vero. Verify the IP address of the NAS and the path to the files. SSH into the Vero and try to ping the NAS as a first step:

ping 192.168.0.18

#5

Does your NAS have a static IP?

Sam


#6

I’ll have a look into that but seems odd as I watched a couple of movies on Sunday through it and they both played fine.

Thank you though.


#7

Yes I’m pretty sure it does. Is it the sort of thing I need to private message you or can I just post it here?

Sorry for the noob question!


#10

From your log you either have 2 NAS, or its changing IPs as you have 192.168.0.18 and 192.168.0.4 as sources.

Make sure your NAS has a static IP.


#11

I think you’ve hit the nail on the head. I’ve added my movies folder again (Movies2) and they now play which I’m assuming has recognized the other IP address.

I’ll just need to see how I set my NAS to a static IP which obviously it doesn’t have at the moment.

Many thanks for yours and Sam’s help as I’m a slow learner to all of this!


#12

The easiest way is to probably set a reservation in the router.

Sam