Vero 4k CEC issue


#1

Hi,

I’m experiencing an issue with my Vero 4k. When I’ve been watching a piece of media with it, I’m unable to shut my HT system down. I turn off the TV, the AV receiver shuts down too but then, after a few seconds, the 4k wakes up (LED turns blue if it was red), turns the TV and receiver back on and selects itself as the active input on the receiver.

I’ve done the following:

  • Turned all the wake up and shutdown options to “none” in the CEC adaptor settings.
  • Turned off just about every switch in CEC adaptor settings.
  • Turned off “enable” in the CEC adaptor settings (it now shows as “disabled.”)
  • Unplugged both the remote receiver dongle and my Logitech keyboard receiver dongle so there’s definitely no control inputs waking the 4k.
  • Setting the the CEC adaptor option to put the 4k into standby when the TV is switched off.

None of these has stopped the behaviour.

I just tried turning my Sky satellite receiver on so that it captures the AVR’s interest then switching the TV off. If I do that, the system stays switched off. I do note that applying the setting to go into standby when the TV turns off still works (the 4k LED turns red) even though the CEC adaptor is set as disabled. I also note that the volume indicator on the Kodi menu shows a red speaker with an “X” and the OSMC remote still controls the AVR volume even though the CEC adaptor should be disabled. I therefore believe the “enable” option for the CEC isn’t deactivating it when the option is off.

My setup is:

  • Panasonic TX50EX700B 4k TV
  • Xbox One X plugged into TV HDMI1
  • Onkyo TX-NR616 AVR plugged into TV HDMI2 (ARC)
  • Sky HD receiver in Onkyo HDMI2
  • Vero 4k in Onkyo HDMI3

(Yes I know the Onkyo isn’t 4k capable, that’s why the XBox is plugged directly into the TV, but all my media is 2k currently and I don’t have money to upgrade it to a 4k AVR at this time)

I would be grateful for any help you could offer in fixing this problem.

Thanks,
Paul.


#2

I just had an idea and had a look at the TV.

I have all the VieraLink options enabled and I found that I can control Kodi on the 4k with the TV remote. I remember turning this on for the BluRay player before I retired it. I’m wondering if the standby button press on the TV remote is reaching the 4k after it’s decided to shut down and this is waking it up, even with CEC disabled.

I want VieraLink working if I can as I like that the TV turns the AVR on and off and that waking the Sky box turns the whole system on and switches the Sky box to the screen.


#3

Usually turning off the Active Source setting is sufficient.

If CEC is entirely disabled on Vero, this won’t be an issue. Can you post some logs if you still have a problem?

Sam


#4

CEC is disabled in the periperals menu but, somehow, the TV and Vero are still communicating. This is repeatable and consistent. If the Vero was selected as the current source on the AVR and nothing else was selected since, it wakes the TV and AVR up every time the TV is put into standby.

Log upload: http://paste.osmc.tv/ecoxabeniy

Every option in the CEC adaptor setting, including “enable”, is set to “off”, “none” or “ignore”


#5

Actually @sam_nazarko would need a debug enabled log to troubleshoot. So I suggest you enable debugging, reboot, create the issue and upload the logs.

Also suggest you share the URL from this command paste-log .kodi/userdata/peripheral_data/cec_CEC_Adapter.xml


#6

Note that if you go into the CEC settings in Kodi and uncheck the top option to disable it, you have to reboot before its fully disabled. I struggled with this a bit myself.

Cheers,
Robert


#7

I have noticed a simliar problem, I also have a Panasonic TV but with a Marantz amp.
After watching a Blu ray I can switch off the tv, this will then switch off the amp and Blu ray player.
After watching the Vero I can switch off the tv, this will then switch off the amp. As the Vero is still on the amp goes into bypass mode and delivers the vero picture to the tv, which switches on, which switches the amp on. I then have to switch the amp off, then the tv.
Is it possibly to have the Vero receive the TV off signal and then go into standby, like the blu ray player?


#8

Settings -> System -> Input -> Peripherals -> CEC Adapter -> “When the TV is switched off” -> “Suspend”
This will work if the TV sent the CEC signal.


#9

Thanks @fzinken, you managed to reply as I was trying to delete the post! I had done exactly what you said. I need to learn to try before posting!


#10

No worries, at least we now have a post if someone search for the sollution.
So you can confirm it works?


#11

Sort of. Now I switch off the TV, the amp goes off and the right LED on the Vero comes on.
Then after a few seconds the red LED goes out and the TV and amp switch back on. I think something else is switching the Vero back on.


#12

Yes, must be. Mine stays off till I press any remote button.


#13

It seems that the amp is switching over to passthrough before the vero switches to suspend, so the TV loses the vero signal then suddenly sees it for long enough to switch back on, which then switches the amp and vero back on. The Blu ray player doesn’t behave this way. I don’t suppose there is a setting to make the vero go “CEC deaf” for a few seconds/minutes after suspend?


#14

As the HDMI interface is disabled in suspend the Vero would not receive any CEC. So must be some different.
Suggest to enable debug logging and watch that via ssh while you switch off the TV


#15

That’s interesting. I’m not sure yet how to do that but did get a debug dump that shows this:


21:52:45.387 T:4079587920 NOTICE: Activating standby mode
21:52:45.387 T:4079587920 INFO: Activating Vero standby mode
21:52:45.387 T:4079587920 INFO: Toggle standby state is sleeping
21:52:45.387 T:4079587920 INFO: CApplication::ToggleStandby – Toggle TMDS clock to 0
21:52:45.387 T:4079587920 INFO: CApplication::ToggleStandby – Toggle LED brightness to 0
21:52:45.388 T:4079587920 INFO: CApplication::ToggleStandby – governor will now be powersave
21:52:45.391 T:4079587920 INFO: CApplication::ToggleStandby – HPD locking will now be hpd_lock1
21:52:45.393 T:4079584000 DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
21:52:45.394 T:4079584000 DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
21:52:45.395 T:4079587920 DEBUG: ------ Window Deinit () ------
21:52:45.416 T:4079587920 DEBUG: ------ Window Init () ------
21:52:45.468 T:3879768832 DEBUG: Skin Helper Service --> Kodi_Monitor: sender xbmc - method: GUI.OnScreensaverActivated - data: null
21:52:53.401 T:3944739584 INFO: Toggle standby state is waking
21:52:53.402 T:3944739584 INFO: CApplication::ToggleStandby – Toggle TMDS clock to 1
21:52:53.519 T:3944739584 INFO: CApplication::ToggleStandby – Toggle LED brightness to 1
21:52:53.521 T:3944739584 INFO: CApplication::ToggleStandby – governor will now be ondemand
21:52:53.526 T:3944739584 INFO: CApplication::ToggleStandby – HPD locking will now be hpd_lock0
21:53:04.257 T:3944739584 DEBUG: SetMenuLanguage - language set to ‘resource.language.en_gb’

Does this give any clues?
Thanks


#16

Can we see the full log?

Sam


#17

Is that a link to the hastebin webpage? I don’t now much about security so better check :slight_smile:


#18

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.


#19

When I disabled CEC on my Vero, things got worse. CEC became broken system-wide when the Vero was plugged in to the AVR’s HDMI, even if the Vero was disconnected from the power. This gave me the impression that there is something in the Vero’s circuitry that upsets certain AVRs. If I attached the Vero to the TV and used ARC, the centre channel was missing on multi-channel material.

I recognised my system was unconventional and ill-matched, having a non-4k AVR in a system with a 4k TV and Vero 4k and using the amp in ARC. I decided to rectify this and upgraded the Onkyo TX-NR616 to a Sony STR-DN1080. I also swapped all the HDMI 1.4b cables in the system for Neet Cables HDMI 2.0 leads. All my CEC issues have now gone away.

The STR-DN1080 is a nice piece of kit. Once I had corrected the mistake its auto-setup made (It decided the KEF egg fronts were full-band floor-standers and expected too much of them so the resulting sound was lacking) it became exciting and most pleasing.


#20

CEC still doesnt work for me :confused: never has

Yamaha 3070 AVR, tried everything!