Vero 4K CEC not working, not listed under 'peripherals'


I’ve switched from an original model Raspberry Pi to the new Vero 4K. Everything’s working fine so far except CEC - my TV remote does nothing. Settings » System » Input » Peripherals just has a greyed-out ‘Peripherals’ option.

  • I’ve tried both the HDMI cable that came with the Vero and the one that worked with the Pi.
  • I’ve tried unplugging the TV (a Sony Bravia) and the Vero, leaving them, then booting the Vero, then the TV. I’ve also tried the reverse order.
  • I’ve tried using the TV’s ‘Bravia Sync’ options to activate CEC.
  • I’ve (misguidedly) tried SSHing on and installing libcec2.

Log uploaded to

Where do I go from here, please? Thanks.

I received my Vero4K yesterday and transferred everything from my Pi3 without any issues.

Unfortunately, just like with the OP, I then also found that HDMI-CEC wasn’t working, quickly follwed by that sinking feeling…

Long story short, and just for the record, the culprit was the new HDMI 2 cable. Moved back to the HDMI 1.x cable that I’d been using with the PI3 and I was fully up and running. Yay!

In the OP’s case, I see he’s tried both the old and new cables, so that one seems to have been ruled out.

In terms of boot order, my experience has been that the TV should be powered on before the OSMC box is started.

The one thing that stands out with the OP’s post is that Peripherals option has been greyed out and that he’s “installed libcec2”. I checked my Pi3 and Vero4K and Peripherals has not been greyed out on either - and both show “CEC Adapter: Version libCEC 4.0.2” without me doing anything. So it looks like that’s been a bit borked by the libcec2 (re)install.

Once the libcec issue has been resolved, it might be worth experimenting with the HDMI cables again, just on the off-chance…

Oh, and minor point but aren’t Bravia sets made by Sony? :wink:

Thanks for your response. I did indeed mean to type ‘Sony’!

Re libcec2, the symptoms were identical before and after installing the package, so it seems unlikely that doing so has changed the situation… right?

We resolved this issue a few weeks ago. You can update to the staging repository or wait for an OSMC update tomorrow



Thanks Sam, I’ll stop tinkering and await the update.

Edit: update got CEC working straight off the bat, without any messing around. Thanks again.

Same HDMI cable problem for me, with my TV Sony Bravia and latest March Update. CEC not working.
Use the old HDMI cable resolve the problem, all works fine.