Vero 4K+ completely dead

I just got up this morning and turned on the TV expecting to find the Vero Home Screen waiting for me. Alas, no signal. I turn to the cabinet and find the little thing. No light in the + sign. Ah okay. I try to unplug and plug it in. Still nothing: No light in the Vero and no signal on the TV.

I then try another power outlet (on the odd chance that one of the four outlets in the extension was faulty), but no dice. Still nothing.

My guess is that the power supply has committed seppuku sometime during the last two days. I have tried to measure the voltage on the PSU, but the meter reported 0.0V on the output when plugged in to power. I am unable to remember if the PSU normally has a red LED lighting up when connected to power, but if it has, it is not turning on.

Is my PSU dead? And more importantly, could my Vero have taken any damage?

Hi, you should see red light coming from the optical port of the Vero 4k+. The front led of the Vero only lights up while booting or when the box has been shut down; in normal operation mode it is dark.

Another “test” (don’t use it as normal operation mode) is to power the Vero by one of the USB ports. So, you need a male-male USB cable for this and do not connect the power supply the same time.

Hi JimKnopf,

Thanks for your reply. I have tried testing it again, and no light is seen in the optical port. I don’t currently have a USB A male-male, but will see if I can procure one today.

I got hold of a USB-A cable, and have tried powering the Vero using it, and that managed to get some power to the front + sign.

Unfortunately, it glows red. No signal on the TV and no light in the optical port (as far as I can see). No answer on SSH as well.

Will a reinstall solve this issue? Is it a PSU issue, or am I so out of luck that the Vero might have died?

Well surely sounds strange that USB is not at least booting it up, also what could have let to the failed power supply.
Which USB port are you plugging in the USB A cable? What are you using to power the USB with?

Do you have a multimeter to check the original power supply?

I have tried both the “white” and the “black” USB port (the white being the one closest to the side with the HDMI port). None of these powers up the device, but both manage to get light in the optical port now.

Sometimes the + sign lights red when plugged into the white port, sometimes it does not light up at all (still light in the optical port). The same is true for the black port, and is true no matter which USB charger I am using. When the light is not lighting up, there is still no signal or SSH connection. Nothing else is connected to the Vero, and I have tried even without a HDMI cable.

I have tried three different USB power supplies: An iPad 5V, 2A charger, a iPhone 5V, 1A charger, and a random USB 5V 1,5A charger I had lying around. I know they are designed to charge a product and not supply continuous power, but I don’t have a proper PSU to test with.

As I wrote in my first post, I have measured the PSU output with a multimeter which reported 0.0V output. I just redid the measurement, and the results are the same.

I have no idea what have caused the issue. It is a few days since I have used it last, but it have been plugged in the entire time.

Is there any other TV or TV’s hdmi port available to eliminate the chance of having a defect TV hdmi port/cable?

The normal behaviour of the Vero 4k+ while power on is that you see the red front led shining for some seconds and then it goes off on successful boot.

If you see another behaviour it means something is wrong with the device … and yes, a re-installation is a good idea, then. But if you don’t see anything on TV while booting from the installation sd-card and you’re sure your TV + hdmi port/cable is fine … you know there is a serious problem with the device. From here @sam_nazarko could further help with some instructions how to recover the boot image.

If you can re-install the Vero or at least start the installation procedure with some signs of life on the TV using the USB power, you know you only need a new PSU for it.

Good ideas. I have tried changing to a cable and port on the TV I know works (got picture on both before and after the test with the Vero) and that did not change anything.

Managed to get a reinstallation image copied to a SD-card, but when I plugged it in, the same happens as previously: No signal or anything, and the red plus keeps lighting red. To somewhat answer the last paragraph: I see no signs of life besides the red LED from the plus and optical port :frowning:

Can you show a screenshot of the contents of the SD card so we can verify if it has been imaged properly?


Yes, sure thing. This is from my Macbook, though the SD card was made by the Windows version of the installer on another machine.

jonas@Jonas-MacBook-Pro NO NAME % ls -la
total 476272
drwxrwxrwx@ 1 jonas  staff       4096  4 Jul 17:46 .
drwxr-xr-x  6 root   wheel        192  4 Jul 17:46 ..
drwxrwxrwx  1 jonas  staff       4096  4 Jul 17:46 .Spotlight-V100
drwxrwxrwx  1 jonas  staff       4096  4 Jul 17:46 .fseventsd
drwxrwxrwx  1 jonas  staff       4096  4 Jul 14:55 System Volume Information
-rwxrwxrwx  1 jonas  staff     112640 27 Dec  2020 dtb.img
-rwxrwxrwx  1 jonas  staff  219197388 27 Dec  2020 filesystem.tar.xz
-rwxrwxrwx  1 jonas  staff   24522752 27 Dec  2020 kernel.img
jonas@Jonas-MacBook-Pro NO NAME % 

Ok, this looks OK to me. The filesystem on the SD-card should be FAT32.

Next step you can try is the toothpick method:

  • on the SD card rename ‘kernel.img’ to ‘recovery.img’.
  • insert the SD card in the Vero
  • get a non conductive pin, such as a wooden toothpick and place it in the rear audio port nearest the HDMI port. You should hear an audible click as the switch is pressed.
  • power on the Vero with the SD card in using the USB cable, no other USB devices connected, holding the toothpick in until you see the OSMC installer. This will force the Vero to attempt to load the installer from the SD card

If that also fails, @sam_nazarko needs to send you some instructions for another recovery method.

I wonder what could have caused this the original PSU and the device are corrupted/bricked the same time.

The SD card is indeed formatted as FAT32 according to the macOS Disk Utility.

I have tried the toothpick method (including renaming to recovery.img) , but unfortunately, that did not help either. The + sign turns red immediately after the USB cable has been inserted, and does not change colour or state. I gave up on seeing the OSMC installer after 20 seconds of holding the toothpick.

I have no idea what have caused the simultaneous meltdown, but my own theory at this point is that the PSU have died in some less-than-graceful way and fried some circuitry in the Vero while doing so.

Anyone else have any suggestions I might try? Does @sam_nazarko have any suggestions I might try when everything else have failed? Or should I simply consider the device dead? In that case, I have to figure something out for local media playback :slight_smile:

Did you get it going? Mine has dropped dead too! It did not last long. Disappointing. : (

I’d recommend starting a separate post outlining your issue in detail.

Is the device showing up in Device Manager on your PC?

If it is, then a low level format should solve the issue


Ok, thanks. Done.

Great - because you don’t see any light but OP does, suggesting a different issue.

Thanks for your response, Sam. Unfortunately, the Vero does not show up in device manager; Windows does not even acknowledge that something has been connected.

At this point I have written it off as dead (or at least from what I am able to do), so if there is anything I can try, no matter how risky, let me know :slight_smile: