Vero 4k Corrupted partition

So I’ve had a lot of fun this week experimenting with my new Vero 4k.

Very nice kodi box and certainly very nice software. Unfortunately I think I’ve managed to corrupt the main root partition (probably pulling the plug before the box had powered off properly). Booting the Vero WAS dropping me to a command prompt and complaining that it couldn’t find dev/vero-root.

Being the adventurous sort I decided to try installing LE to the nand to see how much better it would perform rather than just on sd card. That’ worked perfectly so I still have a functioning box, just not with OSMC!. I kind of assumed the Vero 4k restore image would re-partition, reformat and reinstall everything necessary to get me back up and running once I had finished experimenting.

That hasn’t worked out so well, I’m just getting a message saying there’s a hardware fault upon booting the restore image and to contact support.

So I’m currently in the position of having a Vero 4k, but with the wrong software installed (LE is booting fine from the nand)!

I’ve had a poke about via ssh, using blkid to check etc and seem to have managed wiped all trace of osmc, sigh.

Is there a way to force a re-install or way to manually fix the partitions and re-install?

I’m not in a big hurry to fix it, I’ve still go a working box and it’s mainly been self-inflicted anyway :slight_smile:


Installing LE on Vero 4K isn’t really recommended. If you must run it, it’s better to run it from the SD card.

I’m not aware of anything that OSMC won’t do on the same SoC that LE will do. I understand you had some problems with VC-1 but I’m about to make some fixes available for testing.

Unfortunately I don’t know what LE’s install would have done to the eMMC, so I can’t really advise remotely.

If you send it back to us, we can restore the device with OSMC. It would be hard to debug these changes remotely, and know how to restore them, as we’re not familiar with LE nor do we know if it can run the tools needed to restore Vero 4K to a state where it can run OSMC under this system.

That’s what I was thinking the solution would be.

Easy enough on your end, too difficult on mine without the tools/know how.

Just to be clear the error from the installer was showing up before I installed LE to the nand. Everything was working fine until I updated to a nightly build of osmc with Kodi 18. Then when I decided to restore to the stable monthly release the installer threw up the error and after that the box wouldn’t boot properly.

So I think a return would have been needed anyway.

I doubt very much the update to kodi 18 osmc was the cause, seems much more likely to have been me pulling the power too soon before running the installer. Not that i can recall doing so but an update the a nightly version of osmc shouldn’t have caused it. But I thought you should know just in case.

Could you tell me the return address and I’ll bung it in the post today.

Then I’ll go and order my new Atmos reciever to make me feel better :slight_smile: