Vero 4k+ dead?

#1

A little under a year ago I bought a Vero 4k+, which I’ve been very happy with. Until suddenly it seems to have died on me. I don’t know if it’s the power supply or the Vero itself, but one day last week it just no longer turned on (cross doesn’t light up at all). I’ve tried different sockets, but to no avail. I don’t have an alternative power supply to try. But perhaps I’m missing something obvious, I have a habit of that.

Any suggestions on how I can solve this, other than returning the Vero?

#2

It sounds like you would probably need to send an email off to support@osmc.tv with your order number.

#3

Try and power it with a USB cable

#4

Is there a different way to power up the Vero without the power adapter?

#5

Yes.

You can use a USB A cable.

1 Like
#6

Any of the 2 slots will do? And plug it into a 5V 2A source?

#7

No – you should only provide 500ma via this port.
It isn’t recommended, because it won’t deliver enough power for external peripherals. This should only be done for very specific setups, i.e. cable management when using the device in a museum etc.

1 Like
#8

Thanks, Sam. To clarify, you mean an A to A cable? I don’t have one of those, but since I’m traveling for the next week anyway, I might order one and try your suggestion once I get back home.

#9

Yep

#10

Very interesting. Does this mean that if I don’t use an USB HDD (and hi other peripherals such as DVB sticks) and would only access a NAS over the network then it would be OK to power it from USB only?
Any other drawbacks?

#11

Yes. But that’s not really recommended.

If you do use the USB power idea, do not use your TV or other device that may be powered off suddenly as a power source. Just like with the Pi, sudden loss of power can cause filesystem corruption.

1 Like
#12

Back home, tried the USB cable, which does power up the Vero. Thanks for the suggestion! So presumably the power supply (or its port?) is defective. Would that fall under the warranty?

#13

Yes. You can contact support@osmc.tv with your order details.