Vero 4K+ disrupts ARC functionality

Hello,

since a few days, I own a Vero 4K+, and I am mostly happy with the device.

My setup is a LG Oled 55C7 connected to a Denon AVR-X3500 via a HDMI ARC cable, and this was working flawlessly all the time.

However, once I connected the Vero 4K+ to the receiver, the ARC was no longer working (no more audio). After a lot of unsuccessful debug, I disconnected the Vero and everything was working again. I then used a HDMI adapter with a disconnected CEC pin on the Vero, and everything was still working correctly.

I disabled all CEC functionality in the Vero settings, but that doesn’t help, every time I connect it with a standard HDMI cable to my receiver, the ARC connection between TV and receiver stops working. Anybody else with this problem?

One more small annoyance with the Vero is that the menus are very sluggish and stuttering. I am using the Aeon Nox Silvo skin, running at 1080p 60fps and almost no add-ons except for Trakt. When I use the OSMC skin, it gets slightly better, but is still far from smooth. Playback is absolutely flawless, all video files I tried run perfectly, the problem is only in the menus. Any ideas?

Greetings from Germany,
Michael

Are you on the final update? On the final update with the OSMC skin the menus are butter smooth for me.

Yes, latest update.

Is your GUI resolution set to 4K or 1080p?
Can you post some logs so we can see if there is anything to cause the slowdown?

When you experience the ARC problem, is the Vero 4K + on (powered)?

GUI is set to 1080p 60fps. How do you want me to take the logs? Just reboot, go a bit through the menus until I see it stuttering and then make a log using My OSMC?

The ARC problem is happening when the Vero 4k is on. Have not tried yet with Vero connected but unpowered.

Yes. Be sure to enable debug logging too.

I’d expect it if the device was unpowered but not if it was powered.

Sam

Uploaded log under https://paste.osmc.tv/wawimafosa . This was using the OSMC skin.

With logging active, I noticed my fps dipping down to 8-12 fps in the My OSMC screen without me doing anything, so something seems to be wrong there.

The fps is not an issue when in the GUI. The menus have no reason to update any faster than that. The fps reading is also still only a reference to the GUI and text overlay while video is playing. I believe this is a Kodi limitation.

Just pulled another log, this time using Aeon Nox Silvo, maybe this helps:

https://paste.osmc.tv/holoviyode

Anything else I can do to help debugging those problems?

I’ll give you an update on this shortly.

I don’t want to sound rude, but could you please define “shortly”? (Just kidding :slight_smile: )

Could it make sense to completely reset the Vero and try from scratch? If yes, how would I do this? I did not find a “reset to factory settings” switch.

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

Sorry — I looked over the log but saw nothing obvious here.

Sam

Hi again,

yesterday I re-installed OSMC via SD Card. I then installed nothing and added no media, I just chose the OSMC skin and went a bit through the menu. Especially when pressing left to open the side menu, I can easily count the animation frames. It is just not smooth at all.

The CPU idle temp is around 66°C. Is this normal?

With this problem and the ARC/CEC problems I have, could it be that I have a defective hardware? Is there a way to run a hardware check?

Greetings,
Michael

66C is perfectly fine. The device can operate up to 120C.

Maybe a small video of the problem with the menus will be helpful.

1 Like