Vero 4K+ drives wrong resolution to projector; setting grey'd out

hi,
I’m new to Vero 4K / Kodi. Just bought a 4K+ intended for use in a video club. When it arrived, I tested it on a TV in my “studio” at home. All was fine, but I had to manually switch the resolution to 1920x1080 50p. All was good.

Then I took it to our clubhouse, hooked it up to the projector, and all I got was 1280x720 60p. Both the projector and Vero confirmed this. The problem here is that the projector is a slave, to adjusts to what comes in on the HDMI port. So I went into the settings on the Vero 4K+, but the section where I had to change the resolution was grey’d out. How can I change it then?

I took the projector home, connected the vero to my TV, the resolution and FPS setting were active again, I changed to 1920x1080 50p. Disconnected the HDMI from the TV, connected the projector, and the setting stayed at 1920x1080 50p. But, after switching all devices off, leaving them of for 30 mins, and switching it on again, it defaults back to 1280x720 60p on the projector (and setting is greyed out).

How can I change this setting if it’s greyed out ?
Is there a way to set this setting default to 1920x1080 50p ?

Thanks for your advice…

Note1: the vero does not have power inbetween club meetings (1x week) as all power is cut when the room is empty. Not sure if this is relevant, but it could be.

Note2: the blue led died within the 1st hour of use… only have the red stand-by led now.

Note3: what is the difference, on the shutdown menu, between the option 1 and option2? My unit runs in the local language, but I’m sure you know what is the first and second item on the shutdown menu (translated to English, 1 is “shut down” and 2 is “system shut down”). As the power gets cut to the unit, which option is recommended to shutdown the unit.

What are the resolutions the projector supports? Could be edid data not correct (maybe HDMI having issues?)?

Suggest to provide logs
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Vero4k+ LED is off by default (that was a feature request being implemented)!

Option 1 (Exit) only exits KOdi to give you an option to go to command line (press ESC on load screen) if ESC is not pressed Kodi will restart automatically

Option 2 (Power Off System) will shutdown the OS cleanly so that you can remove power

Thanks for your quick reply FZinken.
I do confirm that the projector is a full HD unit (supports up to 1080p50). We have happily used it for years with our previous mediaplayer (our beloved Medi8tor 600, which sadly has it’s hdmi port dying after years of very satisfied use) at 1920x1080 50p through it’s HDMI port (same cable as now on Vero). As mentioned, when I managed to set the Vero to 1920x1080 50p after connecting it to my TV, the projector ran 1920x1080 50p on the Vero after swapping cables to the projector. Issue seems to be to set some kind of default upon startup of the Vero.

I have no idea how I can set the EDID data in the projector (JVC D-ILA HD750, also known as RS20).

I’ll have a look into the log thing…

I can confirm that the (quite bright) blue led was working when I received the unit. Then, all of a sudden, no blue led anymore… How can I see now if the unit is turned on if there is no blue led?

Unplug your Vero 4K+. Then plug it back in. The LED should turn red for a second or two, and then go out. That’s how it’s designed to work. To tell if the Vero 4K+ is on, if it’s plugged it, it’s on. If you have a picture, it’s on. :slight_smile:

1 Like

You cannot set an EDID on the projector. You must start the projector first, then start Vero. You should then get all the resolutions the projector is capable of. Another way is with both devices powered up, hit that ‘Exit’ button - Kodi will re-start and re-read the EDID.

Let us know if that works. There’s also another trick you can do to make it easier if you are always going to use the vero with that projector.

When / where did you buy this? What’s the order number?
Vero 4K + doesn’t have a blue LED.

There should be a fix for this in the next update to support hotplugging.

Sam

@Sam: I bought the unit very recently from you(Order #20582 of October 6, 2018). The order confirmation indicates a Vero 4K+, so I assume that is what it is. In the first hour of use, there was DEFINITELY a quite bright blue led in the + (same place where the red is). So somethings weird if there is NO blue led in the device anymore, how can I have seen the bright blue led.
On this choice: I have to say that I really do not understand why there is no “on” led… any device I know has an “on” indicator. I can understand that the blue led I saw in the first hour is considered too bright if used in a dim livingroom or bedroom, but a having no led at all is a weird choice.

@Graham: I tried powering on the projector first, waiting till I had a picture, then powered on the Vero, but this did not solve the issue. Also hot swapping does not reset the projector to 1920x1080 50p. The only way I found, was to hook up a TV set, adjust the display resolution to 1920x1080 and FPS to 50, then unplug the TV, connect the projector. Strangely enough, the resolution setting is most of the time grey’d out, but just now, I could change it (even connected to the projector)… weird. If it would always work, this would be a non-issue (I could just go into the setting, and set correct resolution/fps, and done).

As suggested, I also tried the “exit” and let the Vero reboot, but also then it maintains the 1280x720 60p at the projector.

I have to say that in the 6 years we had this projector, non of the mediaplayers we had before ever had an issue setting the resolution correctly. If we cannot fix this, this is going to be very annoying for use in our hobby club, where we don’t have a TV set handy to reset the resolution. So I really must be able to fix the resolution and fps. Also I don’t understand why I cannot set the resolution (grey’d out).

I may need to use the “other trick”, Graham. Other than 2 - 3 times per years, the Vero will always be used with that projector. And those couple of other times, it will also be a HD projector as well, but a different brand/model (this is when we give a show of our movies in a theater).

Anyway, I impressed with the reaction speed of feedback when posting a problem here, that’s a reassuring sign. I’m sure you smart guys will find a solution.

Leo

We have never produced a Vero 4K + with a blue LED.

You can check if your device is a Vero 4K + under the System Information page.

You can enable the red light to be permanently on if you would like. We removed the blue LED due to a number of complaints.

LeoB:

1.) I don’t understand why the LED being NOT on is such a huge deal. As noted, if it’s plugged in, it’s on. The end. I think as a species we’ve become so accustomed to LEDs on EVERYTHING that we sometimes forget what it’s like to not have any. I have black tape or Dim-It strips on every single LED that could possible annoy me in my bedroom when I’m sleeping. In my movie room, there’s not a single LED visible. The change in the new Vero 4K+ to remove the visible LED except on boot-up was a really, really welcome change - as many of us had kvetched about how bright/annoying it was. This was Sam and the OSMC team listening to feedback and implementing it.

As Sam has said, if you REALLY want the red LED to be on permanently, you can have that! So this really is a non-issue. LED if you want it. No LED if you don’t want it.

2.) That you are sure you saw a blue LED is really, really peculiar. If you turn your unit upside down, it should say Vero 4K+, and as Sam has suggested, it should say similar on the System Information page.

3.) The projector funkiness is definitely a weird one. I’m not sure, either, why you say it’s only 1080p/50, when I’m pretty sure the RS20 is a 1080p/60-capable projector.

@sam : it shows “Hardware: Vero4Plus”… so it would think it’s a 4K+.

I would be OK to have the red led as a power on indicator, but then it should be off when the unit is off (so the reverse of now)… is that possible ?

For sure it supports other resolutions and fps, from 576x720 to 1920x1080, and up to 60 fps. But, as we are in PAL land, we produce movies at 25p or 50p (at 1920x1080 resolution). So it’s not the optimum way to have the Vero (and projector) 0run at 60 fps, having to generate/insert 20% additional frames… for nothing.

The other weird thing is that the display settings are grey’d out (but not always)

I see. I was just quoting you from earlier.

I do confirm that the projector is a full HD unit (supports up to 1080p50).

In terms of trying different cables, you mentioned it briefly above, but it wasn’t clear to me what you had done. And are you directly connecting, with no other devices in between?

In our clubhouse, I used the same HDMI cable we have been using for years, length about 1.2 meter (never had an issue with it before). When testing the issue here at home, I used the short HDMI cable supplied with the Vero. Identical situation with both cables. There is no other device in between the Vero and projector.

Are you able to try a different cable at the clubhouse? I’ve seen some really, really funky things with HDMI cables over the years.

Now, I’m not saying this is definitely the cause of the issue, intermittent or otherwise, but handshaking issues could absolutely be the cause. Having had an HDMI cable working for years is no guarantee or indicator it will work with newer hardware.

I suspect the cable because the RS20 is a pretty “standard” projector. I see no reason the Vero 4K line wouldn’t work with it. But I guess you’ll find out. :slight_smile:

edit

What do you mean “identical situation with both cables?” I’m getting conflicting info from you. Have you tried both cables at the clubhouse or not? :thinking:

Sorry, my english is not perfect, but I don’t see any conflicting information. My post said I tried two things:

  1. I tried the Vero + Projector in the clubhouse with the cable which was in use there for years with the Medi8ter we had before
  2. I tried the Vero + Projector at home with the HDMI cable supplied with the Vero (which I assume to be “good”)

With both cables, the issue is there: sometimes resolution reverts back to 720p, and is not modifiable in the settings.

Yes, I probably have 15 to 20 HDMI cables at the clubhouse, at various thicknesses and lengths, so I can try several (next time I’m there).

No worries. It seems you have the cable situation under control.

I’ll leave it to someone else with more technical ability to help from here… :disappointed_relieved:

That’s really strange I had the issue with the resolution being grayed out but a vero restart fixed that. Did you try to factory reset the projector ? I’m just guessing but maybe it run with the old media player so long that It now for what ever reason fails to handshake with vero. Also have nothing else plugged into the vero or the projector. Computers are funny sometimes

This involves saving the EDID in a file. Ideally, you would somehow get the EDID from the projector, but you could save the EDID from your TV. But first:

Do you mean you are getting the display options greyed out even with the TV? that would be a worry.

Anyway, if you ssh into the vero https://osmc.tv/wiki/general/working-with-osmc-via-the-command-line when it’s showing the resolution you want in the display selection and go:

cp /sys/class/amhdmitx/amhdmitx0/disp_cap ~/.kodi/userdata/

Then those resolutions are saved and available for the projector.

The user may have restored a Kodi backup from another device. This would explain the problem.

Sam

1 Like

Sam, if you are referring to me, the Vero came in 2 weeks ago, and no restore has been done (I don’t even have another Kodi device to restore from). So it’s still as “virgin” as it can be.

Graham, no, with the TV connected I can always modify the resolution setting.