Vero 4K+ goes down after connecting active USB-Hub

first excuse my bad English.
Yesterday i got my new Vero 4K+, the Setup was easy , also the Installation of a few Addons all was alright, till i connected my active 2 A USB-Hub with 3 HDD 1 1TB, 2 500 GB and the Vero goes down so i have to disconnect the USB-Hub and the Vero from current. Then i connected the Vero again and it works till i connected the USB-Hub, the same again. I tried it 7 or 8 times but always the same. Please can you help me.

Greetings from Austria
Johann Kogl

PS: There was no USB-Dongle in the package but i am lucky to own a Rii 8i mini keyboard and this works well.

Check the packaging again.

See this thread

Could be a backfeeding issue. Have you tried the connecting the USB Hub without connecting power to the Vero?
Have you tried the second USB Port on the Vero?
Have you tried just connecting the USB Hub without the drives?

1 Like

first many thanks for yor your addvices but the solution is a different approach.
First connect the vero with power, wait till it booted up then connect the USB-Hub with power and then connect the USB-Hub with Vero, so it works. The USB-Dongel is definitve not in the package.

Yes, that’s the best way. You would not be able to power 3 HDDs from the Vero’s 2A PSU, especially when they are spinning up.